X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox hangs each time i close a tab while flash player is running. No crash, no errors, just hanging.

Posted

Windows 7 64bit Firefox version 19.0.2 Flash Player version 11.6.602.180

Watching a flash video works fine (fullscreen, windowed, no problems at all) but once i close the tab in which the flash video was running, or if the video has run through, all firefox windows hang. Firefox does not crash. There are no error messages. Firefox does not show a "does not respond" text in the title bar. It is not recognized by the task manager to be hanging. Sometimes it even hangs when i open some other tabs while a flash video is running in one of the tabs. I did not see a pattern with this random hang ups yet, but they show the same behaviour.

Now: if i open the task manager and manually kill the flash player process firefox immediately resumes its work. It even seems to respond to mouse-clicks and keyboard input i gave while it was hanging.

Furthermore, i dont know if this is normal, but flash player always starts 2 processes when a video is playing. Killing either of those will automatically kill both.

what i did prior to writing this topic:

- uninstall flash and reinstall newest version
- uninstall firefox and reinstall newest version
- deactivate hardware acceleration of flash player

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/de/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Mehr Leistung und Videoformate für dein HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 5700 Series
  • adapterDescription2:
  • adapterDeviceID: 0x68b8
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 1000 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 5700 Series)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: google.com
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.disable_window_move_resize: True
  • dom.event.contextmenu.enabled: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1363283421
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1301332179
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cache: False
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Amit Kumar Thakur 83 solutions 863 answers

Helpful Reply

Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox are most probably caused by a recent Flash 11.3 update and/or a malfunctioning Real Player browser plugin.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Flash Plugin - Keep it up to date and troubleshoot problems

Adobe Flash plugin has crashed - Prevent it from happening again

Flash 11.3 doesn't load video in Firefox

Other, more technical information about these issues can be found under these Links:

http://forums.adobe.com/thread/1018071?tstart=0

http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html


Please tell us if this helped!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

Try to disable protected mode in Flash.

Question owner

ProtectedMode of flash player did not help, however! Starting firefox in safe-mode, as shown by this link http://helpx.adobe.com/flash-player/kb/flash-player-113-crash-mozilla.html did help!

So what exactly could be the cause for this? I dont think that starting firefox in safe mode everytime i browse the internet can be called a "solution".


Edit: As it seems, deactivating ProtectedMode for Flash Player did the trick as well, but in the first attempt i did not restart my browser so i thought at first it didnt work.

Modified by BecauseIMust

aronzdizzle 0 solutions 2 answers

actually i figured out what is causing this issue after giving up on firefox and using chrome (which i hate) i came back but the flash issue continued so i did some research and found out you have to turn off hardware acceleration in flash if you do this i guarantee you flash wont crash anymore if your watching it full scream and some other 3D application loads and causes flash to crash or you move between multiple monitors and flash stutters and crashes this woint happen anymore if you turn off hardware acceleration. i think this is because of the drivers your graphics card uses even integrated graphics have this problem that i have seen. turn off hardware acceleration and flash wont crash anymore