X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

when opening an fdf file Firefox goes into an infinite loop of opening new tabs. The only solution is to restart the machine.

Posted

When opening an fdf file, firefox goes into an infinite loop of creating a new tab, reading a local file (I think a copy of the fdf file), opening another new tab, reading the same file, etc. The only solution is to reset the machine.

Chosen solution

For now, I suppose the workaround is to open the FDF externally (i.e., in Reader or Acrobat and not the plugin).

You can search for known bugs relating to FDFs, or file a new report, in Bugzilla.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VMware Remote Console and Client Integration Plug-in
  • Foxit Reader Plug-In For Firefox and Netscape
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • Live HTTP headers 0.17 ({8f8fe09b-0bd3-4470-bc1b-8cad42b8203a})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Java Quick Starter 1.0 (jqs@sun.com) (Inactive)
  • Microsoft .NET Framework Assistant 1.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: VirtualBox Graphics Adapter
  • adapterDescription2:
  • adapterDeviceID: 0xbeef
  • adapterDeviceID2:
  • adapterDrivers: VBoxDisp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x80ee
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 8-5-2010
  • driverDate2:
  • driverVersion: 3.2.8.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • font.internaluseonly.changed: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1363294169
  • places.history.expiration.transient_current_max_pages: 22348
  • plugin.disable_full_page_plugin_for_types: application/vnd.adobe.xfdf,application/vnd.fdf,application/pdf,application/vnd.adobe.xdp+xml
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Could you check which application is handling FDF files?

orange Firefox button (or Tools menu) > Options > Applications

In the search box, type or paste fdf and pause while the list is filtered. You may have any number of entries. If any of them is set to open in Firefox in the right column, that can cause this problem. Make sure to change that to "Always ask" or one of the Adobe options. (This article has more background: Firefox repeatedly opens empty tabs or windows after you click on a link.)

If that doesn't help, try disabling the new PDF Viewer added in Firefox 19 and see whether that resolves the issue? There may be some confusion about fdf/pdf. This article lists the steps: How to disable the built-in PDF viewer and use another viewer.

Could you let us know what happens?

Question owner

I noticed the problem with the built-in pdf viewer last Friday and changed all pdf related mime types to be handled by Acrobat Reader. Now, the straight pdf format works, but pdf + fdf produces the behavior I described.

If I set the default browser to IE, open firefox and then try to open an fdf file, then IE opens with the pdf document filled out correctly.

Anything else I can do to fix it? This didn't happen with the previous versions of firefox.

Modified by Sergius

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Helpful Reply

Does this problem with FDF files occur only with files on disk and not files on a web server? In that case... Firefox has some security restrictions involving local files that are not applicable to websites. As an experiment, and recognizing that it really isn't safe for untrusted files you might open, you could try toggling the preference security.fileuri.strict_origin_policy from true to false in about:config. Does that make any difference?

Question owner

The problem occurs with FDF files from a web server (my web server). Changing security.fileuri.strict_origin_policy to false didn't change the behavior. I can confirm though the new tabs being opened try to load the fdf file from a directory called Temp on my machine.

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Chosen Solution

For now, I suppose the workaround is to open the FDF externally (i.e., in Reader or Acrobat and not the plugin).

You can search for known bugs relating to FDFs, or file a new report, in Bugzilla.

Question owner

I wish it was possible to open the FDF externally.

When I try to do that, Acrobat opens the default browser and we're back to square one -- unless the default browser is IE.

Modified by Sergius

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

I wonder why Acrobat opens the browser? Obviously I am not familiar with FDF files.

If you are using an older version of Acrobat, does turning off the View in browser setting make any difference?

Edit > Preferences > Internet

(Note: in newer versions, this setting has been removed.)

Question owner

That option is no longer available in Acrobat XI. It used to be there, I know, but not there "no more". In addition opening an FDF from anything but the browser would seriously overload our technical support.

-- EDIT --

The new way of controlling where the PDF opens:

http://helpx.adobe.com/acrobat/using/display-pdf-browser-acrobat-xi.html

Modified by Sergius

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Cross-reference to your bug report: 852239 – When opening an fdf file, firefox goes into an infinite loop of creating new tabs

JEfromCanada 0 solutions 1 answers

Not sure whether to start a new thread. I have the same "infinite tab" problem when downloading ISO files. I checked, and the automatic action for opening such files is to use Nero.

However, when I download the file, I always choose "Save As" instead of "Open with"

Modified by JEfromCanada

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

With what MIME type does the server send this fdf/pdf file?

Type application/pdf triggers the built-in PDF Viewer, other MIME types will trigger a download action or try to use a plugin that can handle them.
Such an action shouldn't result in using Firefox to handle this file because that will repeat the action.