X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Font rendering is messed up!

Posted

Since I've upgraded to Firefox 19.x, font rendering has been completely broken. Fonts are all messed up, distorted, etc...

See here: https://support.cdn.mozilla.net/media/uploads/images/2013-03-07-20-12-39-1f0313.png

I've read through many suggestions about changing options in about:config, and various other settings, but nothing seems to work.

The browser is totally useless like this.

Any help on how to fix the font issue would be greatly appreciated!

Chosen solution

Try to disable hardware acceleration in Firefox.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

Read this answer in context 55

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Shockwave Flash 11.6 r602
  • 4.1.10329.0
  • Pando Web Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Nexon Game Controller
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Windows 7 Pro 32-bit
Firefox 19.0.2
Never had this problem until 19.x came out.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Chosen Solution

Try to disable hardware acceleration in Firefox.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

BeateD 0 solutions 1 answers

This problem happened to me today. Interestingly in my pre-production environment (apache on a windows 7 workstation) the fonts are messed up. They are smaller and appear squished, almost unreadable. In the production environment (apache on a Linux machine), the fonts look fine (both using Firefox). With MSIE, both sites look identical.

It is also strange that earlier today, the fonts looked fine in both environments (pre-production and production). I have made no changes to Firefox, but as of a couple of hours ago, the font issue bugs me tremendously. If the production environment changes to these fonts, the website is no longer useable in Firefox.

I installed the font-information 0.1 add-on, but the information this add-on provides is that the fonts for the pre-production and production environment are the same. Un-checking the box 'Use hardware acceleration when available' did not help me.

I appreciate your feedback on this problem. Thank you! Beate

I figured out what happened. Somehow I had changed the ZOOM setting. Going to Alt + View | Zoom | Reset fixed my problem. It is still strange that this would only affect the pre-production sites that I prepare in my environment here, but never production sites.

Modified by BeateD

Richard Neish 0 solutions 1 answers

I had really ugly font rendering on some pages in Firefox 20.0.1 on Windows 7 Professional. The fix for me was to turn on ClearType. In Control Panel, Search for "Adjust ClearType text", select "Turn on ClearType", and go through the 4 step turning wizard.

Beautiful fonts in Firefox now!

bellevuefineart 0 solutions 2 answers

I'm on Firefox 20. Since upgrading my fonts are messed up. They're kind of blurry and pixelated. If I resize the browser the issue goes away, but I have to resize it every time I load a new page.

WorldEarth 0 solutions 2 answers

Font issue can be cleared up by closing all programs, go to C:\WINDOWS\Fonts in window explorer, click tools, then folder options on the menu bar, go to True Type Fonts tab, click show only TTF, apply, reboot, FireFox font issue solved

Modified by WorldEarth

Mike2424 0 solutions 2 answers

This helped me.

Tools > Options > Content > Advanced

Set minimum font size to "none". Was "15".

Fixed. FF 20.0.1

bellevuefineart 0 solutions 2 answers

Nothing has worked for me yet. My minimum font size in Firefox was none. I have truetype turned on.

This only happens in FIrefox. Not Safari or IE. This is clearly a firefox issue on Windows. I'm not seeing it on my macs.

gamax92 0 solutions 1 answers

Helpful Reply

The actual problem (atleast for me and a few others) is due to a windows update kb2670838. This update applies performance patches to Direct2D, 3D, and Write related components. The reason disabling usage of Direct2D or hardware acceleration fixes it is because its simply not using those Direct___ functions anymore.

In the Update history, 2670838 is listed as: Platform update for Microsoft Windows (KB2670838) In the Installed updates, 2670838 is listed as: Update for Microsoft Windows (KB2670838)

Again, uninstalling this update solved the problem for me and a few others, hopefully it will solve your problems correctly as well.

http://support.microsoft.com/kb/2670838

rprii 0 solutions 2 answers

Two things . . . make sure that you search for "Adjust clear type" using a Capital "A". Else, no result. Second, this "kind of" work. Most text is great but my Bookmarks Bar is stll screwed up and that is a real drag. Add this to all the "crashes" I have experienced lately and I am about to go back to IE or Chrome.

DonFromOz 0 solutions 1 answers

Using Firefox 22 on Linux (OpenSuSE 12.3) current with patches - have M$ fonts installed. This page/site doesn't render correctly. It could be their problem, of course. but I'd be interested if others see the same mess.

http://www.medibank.com.au/

Thanks,

-Don

Mike2424 0 solutions 2 answers

Using FF 22.0 on Win 7. Looked at the site in question (http://www.medibank.com.au) and is fine on my display. See uploaded image.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Hi DonFromOz

Note that the website is downloading fonts via @font-face rules, so make sure that you have enabled this feature (gfx.downloadable_fonts.enabled = true).

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

@font-face {
  font-family: "DINWeb";
  font-weight: normal;
  src: url("data:application/x-font-woff;charset=utf-8;base64,...") format("woff");
}
        
@font-face {
  font-family: "MedibankIcons";
  font-style: normal;
  font-weight: normal;
  src: url("data:application/x-font-woff;charset=utf-8;base64,...") format("woff");
}
        
@font-face {
  font-family: "BreeMedibankWeb";
  font-style: normal;
  font-weight: normal;
  src: url("data:application/x-font-woff;charset=utf-8;base64,...") format("woff");
}