X
Tap here to go to the mobile version of the site.

Support Forum

Why does Firefox v19 always check for add-on compatibility when starting up?

Posted

Whenever I start Firefox v19 a dialog box opens stating Firefox is checking for add-on compatibility. After a short time Firefox opens with my homepage on the 2nd tab and a Firefox welcome page stating my add-ons are all up to date. I've made sure all my add-ons and plugins are up to date, but I keep getting the same behavior.

Whenever I start Firefox v19 a dialog box opens stating Firefox is checking for add-on compatibility. After a short time Firefox opens with my homepage on the 2nd tab and a Firefox welcome page stating my add-ons are all up to date. I've made sure all my add-ons and plugins are up to date, but I keep getting the same behavior.

Chosen solution

hello, go to firefox > help > troubleshooting information, click on profile folder/show folder and close all firefox windows afterwards. a windows explorer window should open up - in there delete the file named user.js.

for more information see Firefox says it's just updated every time it starts - how to fix

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • 5.1.10411.0
  • 12.0.1.647
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • np-mswmp

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • RealDownloader 1.3.0 ({34712C68-7391-4c47-94F3-8F88D49AD632})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Norton Identity Safe Toolbar 2013.3.0.26 ({F04D2D30-776C-4d02-8627-8E4385ECA58D}) (Inactive)
  • Norton Vulnerability Protection 11.1.1.5 - 3 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Quadro NVS 110M
  • adapterDescription2:
  • adapterDeviceID: 0x01d7
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-19-2006
  • driverDate2:
  • driverVersion: 8.3.1.3
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA Quadro NVS 110M )
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://partnerpage.google.com/ig/dell?hl=en&pid=dell&synd=dell&client=dell&channel=us&ibd=&channel=us&client=dell&ibd=
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • gfx.blacklist.layers.direct3d9: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1358528908
  • places.history.expiration.transient_current_max_pages: 53636
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
3068 solutions 14281 answers

Chosen Solution

hello, go to firefox > help > troubleshooting information, click on profile folder/show folder and close all firefox windows afterwards. a windows explorer window should open up - in there delete the file named user.js.

for more information see Firefox says it's just updated every time it starts - how to fix

hello, go to ''firefox > help > troubleshooting information'', click on ''profile folder/show folder'' and close all firefox windows afterwards. a windows explorer window should open up - in there delete the file named '''user.js'''. for more information see [[Firefox says it's just updated every time it starts - how to fix]]

Question owner

Many thanks, madperson, that worked!

Many thanks, madperson, that worked!
austin23 0 solutions 2 answers

Despite what the answers to a bunch of other questions say, this worked for me:

Delete the compatibility.ini in the profile folder.

Despite what the answers to a bunch of other questions say, this worked for me: Delete the compatibility.ini in the profile folder.