Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox checking compatibility of add-ons every time it starts.

  • 11 replies
  • 174 have this problem
  • 13990 views
  • Last reply by computercq

more options

Every time I upgrade, Firefox begins checking compatibility of add-ons every time it starts. And it brings up the "Hooray! Your Firefox is up to date" page every time too. How to fix?

Modified by francob

All Replies (11)

more options
more options

Hi,

Do you get the "Your Firefox is up to date" message every time you start FF, or only ofter the update?

If it's after every start you can check this article: Firefox says it's just updated every time it starts - how to fix

With Firefox 10 most add-ons will be compatible, making the check unnecessary.

more options

Same thing, and it's more than simply the wrong start page. It scans for add-on compatibility every time, and I have TWO tabs opening: Mozilla start page, and the Hooray! page.

more options

Which security software (firewall, anti-virus) do you have?

Some security software has virtualization features that can cause problems by protecting and restoring files in the Firefox profile folder.


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is a compatibility update available.


See also these articles for some suggestions:

more options

Thank you for your reply.

I have followed all those guides closely without any luck.

I use Avira Free as a Antivirus. It uses no firewall or internet protection. I tried turning it off but the same happens. I use Spyware Guard by Javacool, and turned that off too. I also turned off Windows Firewall, but none worked. I will add that I used Advance System Care 5 by IObit not long before I upgraded to firefox 10, I've noticed ever since I used it, my "recent documents" on Microsoft Word are cleared every time I restart my computer. However, I've made sure Advance System Care is not running in the background or runs on start-up, is it possible it changed some system setting when I ran it?

more options

Pendekarlaut provided answer that worked for me:

1. Firefox orange button>help>Troubleshooting Information

2. Under Application Basics, click Open Containing Folder

3. there will be prefs.js, user.js and sessionstore.js

4. Delete all 3 files

5. restart and done.

more options

Thank you karipallu.

I recently fixed however. I did a complete unistall, but backed up my bookmarks and what not. When I used a program to back up my options, it would always come back with the same problem, but if I only restored my bookmarks and saved passwords, it worked fine.

more options

Thanks for forwarding the solution karipallu. After deleting those 3 files plus a suspiciously named file called compatibility.test.ini my problem went away.

more options

It's Problem With Your Firefox Profile... Just Visit http://www.maherhackers.com/solved-firefox-checking-add-on-compatibility-every-time/ For Solution.

Modified by V3King

more options

That was it! Your solution solved my problem. (In addition, I deleted one additional file that was named something like "compatibility.test.ini".) Once those files were gone, so was the problem.

Many thanks!

more options

That definitely got rid of the problem; however, all of my (many, many) add-on preferences are then lost. Is there a way to retain my add-on preferences? I've spent hours tweaking them....