X
Tap here to go to the mobile version of the site.

Support Forum

Plugin blocked in Add on manager as being insecure, but in the check plugin window it is up to date!

Posted

My "Java Platform" plugin is listed as insecure and blocked in the main Add-ons window and I am instructed use the plugin check page to update. When I go to the plugin check page it shows the "Java Platform" plugin as already being "up to date". What could be causing these opposite pieces being generated in relation to the same plugin?

My "Java Platform" plugin is listed as insecure and blocked in the main Add-ons window and I am instructed use the plugin check page to update. When I go to the plugin check page it shows the "Java Platform" plugin as already being "up to date". What could be causing these opposite pieces being generated in relation to the same plugin?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.10411.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 19.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Check for Updates in Help Menu 1.1 (helpupdate@dagger2-addons.mozilla.org)
  • ColorfulTabs 17.6 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • CoolPreviews 3.9 ({CE6E6E3B-84DD-4cac-9F63-8D2AE4F30A4B})
  • eBay Sidebar for Firefox 2.5.4 ({62760FD6-B943-48C9-AB09-F99C6FE96088})
  • Extended Statusbar 1.5.8 ({daf44bf7-a45e-4450-979c-91cf07434c3d})
  • Flash and Video Download 1.28 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Glass Window Download 1.1 (glasswindowdownload@gmail.com)
  • GlassMyFox 1.2.6 (GlassMyFox@ArisT2_Noia4dev)
  • Menu Icons Plus 2.4 (menuiconsplus@codedawn.com)
  • ModestTab 0.7 (modestab@okolnosti.com)
  • Noia 4 Theme Manager 1.8.0 (Noia4Options@ArisT2)
  • Noia Fox options 2.0.8 (NoiaFoxoption@davidvincent.tld)
  • Skip Addon Compatibility Check 2 (skip_compatibility_check@sdrocking.com)
  • Tab Scope 1.1.7 (tabscope@xuldev.org)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Adobe Contribute Toolbar 6.1 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Inactive)
  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9600 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0622
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 2-9-2013
  • driverDate2:
  • driverVersion: 9.18.13.1407
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9600 GT)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: chr-greentree_ff&ilc=12&type=902615
  • browser.startup.homepage: https://www.google.com.au/
  • browser.startup.homepage_override.buildID: 20130226172142
  • browser.startup.homepage_override.mstone: 19.0.1
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.1
  • gfx.direct3d.checkDX10: False
  • keyword.URL: http://au.search.yahoo.com/search?fr=greentree_ff1&ei=utf-8&ilc=12&type=902615&p=
  • network.cookie.prefsMigrated: True
  • permissions.default.image: 0
  • places.database.lastMaintenance: 1362316189
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1283 solutions 8500 answers

Java, even though it is up to date, is insecure. Why do I have to click to activate plugins?

Java, even though it is up to date, is insecure. [[Why do I have to click to activate plugins?]]
cor-el
  • Top 10 Contributor
  • Moderator
13072 solutions 119680 answers

Please update the Java plugin to the latest 7U17 version. That version doesn't seem to be blocked at this moment.

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U17 (JRE Download)

Please update the Java plugin to the latest 7U17 version. That version doesn't seem to be blocked at this moment. You can find the latest Java version on the Oracle website. See Java Platform > Java SE 7U17 (JRE Download) *http://www.oracle.com/technetwork/java/javase/downloads/index.html *http://java.com/en/download/manual.jsp