X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java Plug-ins detected as not up to date.

Posted

Having run the page to check if my plugins are up to date, I'm told Java(TM) Platform SE 7 U9 and Java Deployment Toolkit 7.0.90.5 are out of date.

However, verifying the Java version, the webpage displays "You have the recommended Java installed (Version 7 Update 9)."

How do I go about remedying this?

Chosen solution

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U10 or Java 6U38 (Download JRE)

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Unity Player 4.0.0f7
  • Nokia Suite Enabler Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • NPWLPG
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Chosen Solution

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U10 or Java 6U38 (Download JRE)

Question owner

Hi there,

Thanks for your reply.

Installed the appropriate program, but it is still showing as out of date.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Which Java version shows on the Java test pages?