X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox has become extremely slow in the recent times

Posted

Firefox suddenly has become very slow. It takes too much time to load all websites and even the typed words and scrolling has a great delay in appearing. It becomes unresponsive very often. I tried reinstalling it and even reset it. Its becoming a pain to use this to surf the net. Please do help!!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.14.17.11865
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • 4.0.60831.0
  • Winamp Application Detector
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Please update to Firefox 19 Update Firefox to the latest version, then reset firefox again Reset Firefox – easily fix most problems

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Try to disable hardware acceleration in Firefox.


A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Question owner

Thx Tylerdowner for your reply. Actually this problem started after updating to firefox 19 oly!! I resetted it and een then it wasn't of any use so oly i came to 16!!

Question owner

Thx cor-el for your reply. I checked and the hardware acceleration is already enabled. There is no restriction in the firewall too..

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

The point is to disable hardware acceleration because this can cause issues with slowing down Firefox if it isn't working properly

Question owner

I disabled it and it seemed like firefox has returned back to its previous state. But now fire fox is slow again !!

Justanidea 0 solutions 1 answers

I was advised to get some extra memory - didn't think it was possible in my old Dell Inspiron 6000 - but I visited crucial.com and doubled from 1GB to 2GB of system memory without any glitches. My laptop is so much faster all round and Firefox has been forgiven (for my ignorance)!

wphurley 0 solutions 4 answers

Same here, but things on my laptop began to degrade after the push-upgrade to FF 20.x occurred. I've reset and uninstalled/reinstalled FF (with a reg clean/defrag in between). I've disabled plug-ins and extensions.

My investigation has revealed nothing conclusive, but I do find the following data points to be curious/interesting. The slowness within FF is episodic. The HW symptom that co-occurs is that my HDD begins to thrash. The HDD lite goes solid and Win PerfMon shows I/O and Queue pegging the meter all while the CPU stays relatively (average 25% util). I also notice that my keystroke inputs will vacillate from instantaneous to slight delays (w/occasional delays that end when an entire sentence I've typed suddenly appears in an FF box - such as is happening when writing this reply).

I've also seen FF accessing the $LogFile and master file table quite a lot. Can't now quantify that access pattern other than as a lot.

There are also times when a download in-progress with suddenly drop from 1.5mbps/sec to 65k/sec and "stay" at the lower bit rate (citing just one of many examples - drawn from various access points and connection bit rates).

Again, all of this has its beginning with the FF 20.x push upgrade.

Help??

Modified by wphurley

jonathan321 0 solutions 1 answers

Firefox 20.0.1 is shit. It's okay for normal surfing. But when you are downloading files, it start to get very slow after a while. It's as if it's hang. Try all there is and still doesn't work.

Switch to Chrome.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

If Firefox gets slow then this is either a profile issue (installed extensions) or a problem with other software (likely security software) that causes problems.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

wphurley 0 solutions 4 answers

Thx for the suggestions, I'll give it a whirl. Just an FYI, before I posted a comment here I had deleted my profile and all data after which I when deleted FF entirely and all data which I then reinstalled to a new directory of a different name (I use %progfiles(x86)%\INSTALL_DATE\FF as my reinstall convention). I was attentive, but not exacting in noting FF's behavior - w/o extensions - in all cases. In each case, FF seemed OK before slipping back into it turtle's pace when downloading.

Are there relatively easy ways to exorcise all remnants of plug-ins (e.g.: java, flash, silverlight....)?

No matter how thorough I've been in deleting registry entries, directories including user\appdata\ files and %winroot%\sysWOW64 files from plug-ins, the "legacy" settings appear no matter how "clean" the new FF install is. I've use CCcleaner, Wise Reg Clean and RegMech behind my manual efforts to rid my registry of deleted plug-in entries - all to no avail.

Modified by wphurley

kfrantzen 0 solutions 3 answers

Helpful Reply

I also have found that Firefox has become a dog. I've followed one thread that disabled the plugin-container with no help. 20.0.1 can hang for over a minute and actually hog my entire CPU so I can't even start Chrome! I like my FF plug-ins, but the performance problems of FF 20 are becoming intolerable and no one seems to know what the heck! Chrome does not present the problems and I have been visiting and working at the same websites. If many folks are encountering this mess, I suspect that FF is done for. I have actually found that the Android FF is also tending to slow down my smartphone - stall it! I am a few days away from just removing FF from my computing life.

slash75 0 solutions 2 answers

Same problem here. Firefox has become so slow I can't even stand to use it. I have tried reinstalling and deleting my profile numerous times with no luck. I think I may be moving on as well unless I find a solution soon.

Modified by slash75

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

slash75 0 solutions 2 answers

Thank You!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I went to a command and typed in: firefox.exe -p Then created a new profile. Then deleted my old profile. Problem solved.

paulo_one 0 solutions 1 answers

Helpful Reply

Eventually your new profile will begin to perform like your old profile so you have to do it again. After three profile changes I solved my problem by switching to Chrome. Still have Firefox but only as a backup.

timjak 0 solutions 2 answers

Fixed! By turning off Adobe Flash Protected Mode - see [https://support.mozilla.org/en-US/que.../953721#answer-444884] which refers to an adobe workaround here.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8022 answers

You may each have different problems, so would do better posting in your own threads by starting a question from /questions/new.

It also helps developers if you turn on telemetry so that anonymous performance data may be sent and analysed.

That feature was introduced after some Firefox regressions were overlooked.

edgeypoo 0 solutions 1 answers

Did you go to options-advanced-network and click choose how firefox connects to the Internet? Few minutes back, I had this problem, and I solved it by disabling my VPN/Privoxy (forgot to turn it off). Switch to no proxy and see what happens.

Modified by edgeypoo