X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

[Bug] Problem with fields within pdf files on Firefox 19

Posted

Hello, I'm having some problems with the new built-in pdf viewer included on Firefox 19. The problem appears when I'm opening a pdf field who have some fields already filled, and one of these fields is a Check Box that must show a check mark "✓". When the viewer opens it, it shows a number "4". If I open it on Adobe Reader, the check mark is shown properly. If, instead of the check, the field is configured to show a cross (X), the firefox viewer works properly. I know how to disable the viewer, that's not the issue here. Here's a screencap to show it:

http://s16.postimage.org/uv9ah32j9/error.png

Thanks!

Modified by FlsSpain

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • iTunes Detector Plug-in
  • Shockwave Flash 11.4 r402
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • ActiveTouch General Plugin Container Version 105
  • 1.138.0
  • 4.1.10329.0
  • NPWLPG
  • 0.70.4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3019 answers

This is weird. It must be the coding of the website you are visiting.. Or you can try clearing cache and cookies.

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

There are still a lot of issues with the build-in PDF viewer that need to be fixed.

They have left the option open to disable the PDF Viewer via a hotfix.

  • Bug 839239 - Need to prepare a hotfix for pdfjs.disabled, targeting FF19 (all platforms)

Question owner

Thanks for the reply feer56, but it is not the cache nor the cookies. It happens to all the computers i've tried with firefox 19.

Thanks for the reply cor-el, I hope my information helps for this issue to be fixed.

Question owner

I've just discovered that I can upload a screenshot, so here it is

Modified by FlsSpain

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

That is a problem with the build-in PDF viewer and may already have been fixed in a next Firefox version.

You can give the Firefox 20 beta with its own profile folder a try.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

You can also try to install the PDF Viewer version from the Add-ons site that is more recent then the version in Firefox 19 (Nightly 22.0a1 comes with it)

Question owner

Thanks for the answers, I'll try them and let you know. I've encountered more bugs like this, so maybe next versions will be better.