X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Is there retina display support for new Firefox 19?

Posted

My Macbook Pro retina just upgraded automatically to version 19. Version 18 had Retina support, which was awesome, but since the upgrade, my browser is pixelated again. Any retina support on the new 19 version as well?

Chosen solution

OK, so it looks like Facebook is now in retina-display...I don't know what happened or what fixed it.

But it looks like things are resolved...somehow.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • DivX Web Player version 2.0.0.263
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Yes, Retina support was introduced in 18 and is still in 19. Try to Reset Firefox Reset Firefox – easily fix most problems

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8028 answers

Retina support was introduced in fx18 but had several issues but should still be supported in fx19.

I can not remember whether it was just fx18.0.1 but at sometimes fixes were to turn it off !! because of the problems. Have you checked it is actually on.

I will have to keep an eye on the me too votes on this thread,if a lot of others have problems I will look at the bugs and see if i can find out anything more over there.

Note the easy option of using Firefox reset will remove your extensions, also alter a few other things,

Modified by John99

Question owner

Tried it, but nothing happened. Google is still fuzzy, for example.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Can you type about:support into the address bar, press Enter, and then copy that information here?

Question owner

Troubleshooting Information



 This page contains technical information that might be useful when you're
 trying to solve a problem. If you are looking for answers to common questions
 about Firefox, check out our support website.







       Application Basics
     



             Name
           
           Firefox
         


             Version
           
           19.0
         


             User Agent
           
           Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
         


             Profile Folder
           





             Enabled Plugins
           


             about:plugins
           
         


             Build Configuration
           


             about:buildconfig
           
         


             Crash Reports
           


             about:crashes
           
         


             Memory Use
           


             about:memory
           
         




       Extensions
     



             Name
           
           
             Version
           
           
             Enabled
           
           
             ID
           
         
       
       
       
     



       Important Modified Preferences
     



           Name
         


           Value
         
       


       accessibility.typeaheadfind.flashBar0browser.cache.disk.capacity358400browser.cache.disk.smart_size_cached_value358400browser.cache.disk.smart_size.first_runfalsebrowser.cache.disk.smart_size.use_old_maxfalsebrowser.link.open_newwindow2browser.places.smartBookmarksVersion4browser.privatebrowsing.autostarttruebrowser.startup.homepagehttp://www.google.ca/browser.startup.homepage_override.buildID20130215130331browser.startup.homepage_override.mstone19.0browser.tabs.loadInBackgroundfalsebrowser.tabs.warnOnClosefalsedom.mozApps.usedtrueextensions.lastAppVersion19.0font.language.groupx-westerngfx.blacklist.webgl.msaa4layers.acceleration.disabledtruenetwork.cookie.cookieBehavior1network.cookie.lifetimePolicy1network.cookie.prefsMigratedtrueplaces.history.enabledfalseplaces.history.expiration.transient_current_max_pages104858plugin.disable_full_page_plugin_for_typesapplication/pdfprivacy.donottrackheader.enabledtrueprivacy.sanitize.migrateFx3Prefstrue
     



       Graphics
     


       Device ID0x 166GPU Accelerated Windows0/1 Basic Vendor ID0x8086WebGL RendererIntel Inc. -- Intel HD Graphics 4000 OpenGL Engine


       AzureCanvasBackendquartzAzureContentBackendnoneAzureFallbackCanvasBackendnone




       JavaScript
     



             Incremental GC
           
           true
         
       
     


       Accessibility
     



             Activated
           
           false
         
         
           
             Prevent Accessibility
           
           0
         
       
     


       Library Versions
     


       Expected minimum versionVersion in useNSPR4.9.44.9.4NSS3.14.1.0 Basic ECC3.14.1.0 Basic ECCNSSSMIME3.14.1.0 Basic ECC3.14.1.0 Basic ECCNSSSSL3.14.1.0 Basic ECC3.14.1.0 Basic ECCNSSUTIL3.14.1.03.14.1.0

Question owner

Let me know if you prefer screenshots.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Let me do some checking around. Meanwhile, would you mind making sure that Mac is fully up to date, Restarting your computer, Trying with Hardware acceleration disabled, etc.? Turning off hardware acceleration

Question owner

I checked and I installed a Java update for my Mac. Hardware acceleration is turned off...

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Can you play with Hardware Acceleration? Is it better with it on? Better with it off? After a restart, etc.?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)

Question owner

I honestly don't see any difference between having Hardware Acceleration on/off. Even after a restart.

Question owner

Hi, have you found a solution?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Try to set the gfx.hidpi.enabled pref to 2

Question owner

Tired that; no dice.

felipe.rodrigues 0 solutions 1 answers

@smuggin

Try this:

on Firefox 19

about:config

___

layers.acceleration.disabled = true

gfx.hidpi.enabled = 2

___

Restart Firefox.

ps: I work with Flash and the only problem is that Flash player is soo soo soooo laggy now. But everything else works perfect.

Question owner

Google is now working. Facebook logo is still grainy, as are some graphics on this help page. Eh, good enough for me.

Chosen Solution

OK, so it looks like Facebook is now in retina-display...I don't know what happened or what fixed it.

But it looks like things are resolved...somehow.

rukkuz 0 solutions 1 answers

Is there any other fix to make Firefox 19 look better on the MBP Retina?

I tried changing the values in about:config but i didn`t see much differance at all..surely there must be a way to make FF look sharper on the retina display.

I still think it looks very soft and also kind of fuzzy on my Retina display.