X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Slow/unresponsive when woke up after sleep - Windows XP SP3

PLP
Posted

Since, I think, the latest Firefox update to version 18.0.2 the browser is very slow. It seems like it does not respond after I bring the computer up from sleep (S3 state, but not hibernating).

It works like that - I leave some tabs open, put PC to sleep, wake it up, and I can't type in to web-login into my email account. If I want to switch tabs, it takes a quite few seconds to switch. It DOES switch, but it takes loooong time. However, it will respond to close right away. Once closed and opened - it works just fine. Of course till next sleep...

Any solution?

It is my work PC, Windows XP, SP3, 32 bit. Symantec Endpoint Protection.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Shockwave Flash 11.4 r402
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • 5.1.10411.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Tylerdowner thanks for the quick response.

I followed your suggestion and... it did not help. Firefox behaves same way.

However, after reset it stated the browser is out of date (apparently version 19.0 was just released).

Hence, I updated it and it seems it is OK now. I will keep you posted if the update solved the issue here.

One thing I can add is that this machine is the only affected one. My home computers (WIn7, 64b) do not suffer from it.

Question owner

OK, so here is the update.

Problem is back. I just put the computer into StandBy and... Firefox does not respond.

Let me give you more details I just discovered.

Lets say you have open three tabs. Tab A, Tab B, and Tab C.

On the Windows Taskbar you see the the title of the currently chosen tab, right? So, I am on TabA, taskbar shows TabA. I click (after wake up) on TabB, Firefox still shows me TabA, but the taskbar shows title of TabB. It takes about 5-8 seconds for Firefox to update the view, UNLESS I minimize it or switch to anything else (Outlook, Explorer...) - any other window will do. Then the browser will switch to Tab B immediately.

However, it is still slow if I go back to the browser. It will not pull down the remembered logins. It will not follow any links... It will switch to Tab C the same way as it is described above. Of course, it responds to close right away.

Any clue?


I do not see any other issue with this machine whatsoever.


EDIT: to add to comments below - it does not seem to be plug-in related.

Modified by PLP

Kognix 0 solutions 4 answers

Hi,

i have the exact same problem. System: Win 7 (64bit) It appeared after I woke up my computer out of the sleep mode. After a short time period most likely the flash player slows down, nearly freezing. Page scrolling isn't smooth. It's like beeing back in the 90's. I've restarted the Fox, updated all plugins/extensions. Restartet my computer... It seems after a second restart of the Fox it has been updated to v19. I'm waiting now if the problem still occurs. Reporting out.

EDIT: Forgot to add that I have many tabs open. Round about 200 but that ones what I need only load if I click on them

EDIT2: Problem occured again. After I visit some websites the framerate goes dramatically down.

Modified by Kognix

Question owner

I just run a few more tests.

Two scenarios: 1. Three tabs open - all blank (new tab). After wake up - Firefox works just fine. 2. Three tabs open - two blank and one of those I keep open (gmail.com). Firefox unresponsive. I tried same thing with different tab (poczta.o2.pl) instead of gmail and same result. However, when I manage to close the tab (gmail or poczta) Firefox becomes alive again.

So, what could be the problem? If plug-ins - which are in use on those sites?

thanks

Kognix 0 solutions 4 answers

I started a complette fresh installation. Same problems as allready mentioned.

My Firefox details: http://pastebin.com/RWvTHZ1k

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

cor-el, that helped. At least it seems so now...

I was wondering though. Why did that happen? Everything was fine for over a year and all of sudden I started having problems. Nothing was changed. No new hardware, no new software (except Firefox updates and some MS updates...)


EDIT.

No, it did not help... After another attempt of "stand by" the firefox froze again... I disabled the hardware acceleration, restarted Firefox and tried "stand by/sleep" mode. Woke it up and the browser worked fine. No problems. So I posted the update.

I tried one more time sleep - and here we are again.

I give up.

Modified by PLP

Kognix 0 solutions 4 answers

I can confirm that!

Turn hw-acceleration off doesn't help. Firefoxs behave is generally slow. Even with or without. It doesn't react fast to inputs with keyboard and mouse.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

This can also be caused by plugins or the plugin-container process that isn't initialized properly.

Question owner

There are 13 plug ins. I disabled all of them. All are up to date except Adobe - admin rights do not allow me to update it. Nor can I update Java.

Anyway, plug ins on or off - no change...


EDIT:

I am sorry, correction. After disabling all of the plug-ins I did not restart Firefox, as it was said I did not have to. However, after waking PC up, all plug ins were still enabled... So, I disabled them again, restarted browser, and it works. Tried 2 times - seems to be OK. Now I must play with them to see which one causes the problem... Any suggestion how to find the bad one?


2nd EDIT:

Nope, back to square one. I just tried one more time and the problem still persists. All are disabled. Verified.

And I want to repeat one thing here. This problem started a few weeks ago.

Admins or Mods, think maybe of a better title of this problem for search purposes...

Modified by PLP

Kognix 0 solutions 4 answers

Yes, exactly the same by me as it happens by PLP.

I think it could be an issue in the Firefox Javascript. Firefox itself slows down, open the menu takes a few secs and so on.

EDIT: We can't be the only ones with that problem!? I have to use Chrome while this isn't fixed. :/

Modified by Kognix