X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox copy feature always adds extra space before or after when double clicking to select text

Posted

I have only just started using Firefox but I've noticed a strange "feature" (I'm not sure if it's a feature or a bug, thus the quotes). I'm used to Opera and IE where by when I double click some text the text will be automatically selected. Firefox does something like this but for some reason I don't yet understand it adds an extra space at the beginning or end of the selection. This is a problem for someone like me who for work does a lot of copy and paste. I use web software that is intolerant of extra spaces and this feature/bug is going to end up causing some major issues. Is there a way to alter this behavior so that it behaves more like all my other computer programs? Your help is greatly appreciated.

Chosen solution

Well, unfortunately, the solution didn't work. I guess it's back to Opera as it seems to be the only browser that has the features I need. Too bad.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • Google Update
  • Foxit Reader Plug-In For Firefox and Netscape
  • VLC media player Web Plugin 2.0.2
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Unity Player 3.5.5f2
  • Winamp Application Detector
  • 5.1.10411.0
  • Intel WebAPI Updater - Installs and updates Intel WebAPIs
  • Inte IPT Web API
  • Zeon PDF Plugin For Mozilla
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Double click text, right click and select copy, paste text, notice spaces, slap forehead, carefully select text and copy all while cursing Firefox for it's stupidity.

the-edmeister
  • Top 10 Contributor
  • Moderator
3196 solutions 24401 answers

Does click and drag across the text, then use {Ctrl + C} to copy the highlighted text, exhibit that extra space when you paste using {Ctrl + V}?

Question owner

Thank you Ed for your reply. To answer your question, no it does not, and that is the unfortunate work around I'm currently, delicately using. The problem is that this is much slower than double clicking and I do a lot of copy/paste. Also, I've experienced another problem with Firefox pasting. I regularly (and I mean every ten minutes or so) copy text from a webpage into TinyMCE. The problem is that when I paste, Firefox pastes improperly formatted rich text. My work around is to paste into text editor and then back out. Is there a simpler way to do this in Firefox?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

This can happen if there is HTML code included in the selection.
You can verify that by opening View Selection Source via the right-click context menu.

bamzero 0 solutions 1 answers

Helpful Reply

Not sure if this will help with your issue, but can try.

In the URL bar type about:config

Then change layout.word_select.eat_space_to_next_word to false.

Modified by bamzero

Question owner

Thank you for the suggestion Bamzero but no, it just tries to find a webpage called config.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi bullywug, to access Firefox's "about" pages, do not include any spaces in the name. So in this case, about:config with no spaces (and no http:// before it).

Question owner

Thank you. I missed the "about" part. It's not a perfect browser but it'll do for printing labels on Paypal (that's all I use it for). Thanks again.

Chosen Solution

Well, unfortunately, the solution didn't work. I guess it's back to Opera as it seems to be the only browser that has the features I need. Too bad.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Does leading or trailing space show as selected if you double-click the space between two words or double-click a word after setting the pref to false?

Did you check the selection source via the right-click context menu?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

I'm not sure why you would get an extra space at the beginning. If you get a space at the end after double- or triple-clicking, or if you want to omit punctuation from the end, you can back the selection off the last character using Shift+Left Arrow. Depending on what is included in the selection, this could take a couple of tries.


By the way, toggling the above-listed preference worked instantly for me. Just to recap the steps:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste select and pause while the list is filtered

(3) Double-click the layout.word_select.eat_space_to_next_word preference to switch its value to false. You're done here.

Switch back to your tab with selectable text and test. If you still get the trailing space after a word, I wonder whether an add-on might be interfering?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

If you select text with the mouse then you can get leading or trailing spaces.
Bugzilla is one of those pages where I always get a trailing space if I select the Bug title with the mouse. In this case it is caused by tags that get included.
With double-clicking a link this shouldn't happen.

Question owner

Hey guys, You are all very kind to continue to try to help. The problem with the text selection is on double clicking a non-hyperlinked word. Sometimes it functions properly with the setting turned on and sometimes it still adds spaces. Unfortunately, I am self employed and don't have time to continue to troubleshoot. That is why I've marked this problem as solved. These aren't the only problems I've experienced since switching. I had hoped to have a single web browser for everything but that just seems to not be possible anymore. My webstore only works with Chrome or Opera, PayPal only works with Firefox or IE and my suppliers sites sometimes work with one and sometimes another. So I'll continue to use multiple browsers for now. It's not the end of the world. Still, thank you all for you kind support. -Charles