X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Downloaded file from Firefox but it is not opening in the internet explorer

Posted

1. I have java script file where it will download the content to a xml file . Below is the java script code

  // "data:application/octet-stream," + encodeURIComponent(content);
   var dataURL = "data:application/octet-stream," + encodeURIComponent(textToEncode);
       window.location.assign(dataURL); // To change the current page
2. when we are trying to open downloaded xml file in internet explorer  through the javascript it is throwing Type Error : Access denied .    But, when we open the xml in notepad++ and re- save it is able to open in internet explorer. 
   below is java script code to open the xml file - 
if (window.ActiveXObject) {
           xmlDoc = new ActiveXObject("Microsoft.XMLDOM");
           xmlDoc.async = false;
           xmlDoc.load(fname);  // fname refers to the file path where we downloaded
           return (xmlDoc);
       }

i am not able to resolve the problem .can you please help me on this . Thanks in Advance

Chosen solution

Try to set the browser.download.manager.scanWhenDone pref to false on the about:config page to suppress zone information (ADS).

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Microsoft Lync 2010 Meeting Join Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.1.10329.0
  • HttpWatch Basic - HTTP Viewer for Firefox
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

After restoring also still i am having the same issue .

 Input from my side is - when i  am trying to open the downloaded xml file in the internet explorer  it is throwing error -'Your Current security settings does not allow this file to be downloaded - but after opening the same xml in notepad++ with out changing anything if i resave then the same xml is opening in internet explorer i predict that while saving is i am missing any setting in javascript can you please check the code what i have updated previously.
cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Chosen Solution

Try to set the browser.download.manager.scanWhenDone pref to false on the about:config page to suppress zone information (ADS).

Question owner

Thank you so much :) . It is working fine now

Now i want to do the same through the javascript code where the application is running . Can you please let me know is there any registry entry for this or javascript code for this . Thanks in advance .

Question owner

I need that setting to be applied when we are launching the application and on close of the application i need to reset to the old . Can we able to do the same in the java script .please help thanks :)