X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I uninstall the standard American dictionary? I only want to use the English/Australian dictionary.

Posted

I do not want to use the default American dictionary. Although I have the English/Australian dictionary installed, every time I use a word that in Australia has an 's' but in the States has a 'z' the word in highlighted as incorrect. For example. Australia: 'organisation'. US: 'organization' - the word 'organisation' is highlighted as an error although it is not. In other words, the US dictionary takes precedence over my installed English/Australian dictionary which makes that English dictionary totally superfluous and makes me wonder why it's offered in the first place. I would like to remove the US dictionary but can't find it to kill it.

Chosen solution

In Linux you will find dictionaries in /usr/lib/firefox/dictionaries. You will need root privilegies to delete them.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • VLC media player Web Plugin 2.0.2
  • 4.1.10329.0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • CANON iMAGE GATEWAY Album Plugin Utility Module

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

alco 18 solutions 141 answers

Hi robin1111,
you could see more information in this article:
How do I use the Firefox spell checker?

Helpful Reply

Thanks for this. The only problem with it is that as soon as I have either left that text field or closed down Firefox, the US dictionary is reinstated as the default dictionary. I don't want it there at all so that I only have to select the other dictionary once and have its status in Firefox as being the default from then on in. For example, in this text field the default is US, however on another web page currently running the default is Australian. However I know from experimentation that the default of Oz in that text field is only transient, it will revert back to US once I have closed down that page. I want to kill the default as set and make my own selected dictionary the default for all subsequent Firefox sessions.

alco 18 solutions 141 answers

Which locale do you have installed?
Create a new profile as a test to check if your current profile is causing the problems.
See "Basic Troubleshooting: Make a new profile":


There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.
If that new profile works, then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.
Hope it helps!

Question owner

Thanks for this.

I have tested the thesis that it could be my profile that is causing the problem. I did that by utilising the Linux Virtual Machine I have on my desktop and it kept the preferred language even after a complete reboot of the VM. In fact the VM is on my main screen along with it correct settings as I write this on my Windows 7 machine with its incorrect settings. One question: do I have to create a new profile or can I just disable every plugin and extension and test from there? If not, does this mean that some plugins and extensions write to the Firefox core and even if the plugin/extenision is disabled that code is still extant within Firefox?

Question owner

Disabling didn't work. Therefore will try the new profile.

Question owner

I have created a new profile and only added the Australian Dictionary only as an add in. I'm still getting the same problem. What makes this interesting is that my Linux profile which only has the Australian dictionary within it (like the MS version) does not contain this error. I haven't the first idea why this should be happening and have no other recourse than to mutter imprecations about Microsoft. I've checked the Windows settings and it is definitely set to Australia with the language and measurement being Australian.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Helpful Reply

A possibility is to install the en-GB Firefox version as that version doesn't come with a dictionary like the en-US version does.

Otherwise you can find the en-US dictionary files in the dictionaries folder in the Firefox program folder and remove them there.

  • (32 bit Windows) C:\Program Files\Mozilla Firefox\
  • (64 bit Windows) C:\Program Files (x86)\Mozilla Firefox\

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can look here for dictionaries:

Question owner

That fixed it. Thanks. I just changed its name there and all is OK. Once again thanks.

Bones42 1 solutions 3 answers

I have had a recurring problem with this. On Yahoo and Facebook, Firefox switches back to US dictionary when I switch tabs.

So the solution was to delete the files in Program files x86/Mozilla Firefox/dictionaries. 2 files deleted, problem solved.

That was the only thing that worked.

jalyst 0 solutions 24 answers

So far, so good, I thought it didn't work at 1st, because the spelling tool wasn't appearing at all on the context menu. But that was because I was trying to check spelling on a normal page instead of inside a text box, like this one I'm typing in now. This was such a annoying bug, it used to always switch back to US spelling, even though I'd installed the Australian (UK) dictionary & set it as default! Thank goodness for this community...

Modified by jalyst

Question owner

The initial solution of killing the US dictionary within C:\Program Files (x86)\Mozilla Firefox\ (64 bit) worked well once the Australian dictionary was installed. However, when an update is installed it appears to once again reinstall the US dictionary so deleting it has to be a part of the reinstall or you're back at square one.

What I'm curious about now is why both the installed UK and Australian dictionaries aren't showing in the dictionaries folder. Where are they?

Bones42 1 solutions 3 answers

C:\ProgramData\Mozilla\********.default\extensions\en-GB@dictionaries.addons.mozilla.org

There is a dictionary folder there.

jalyst 0 solutions 24 answers

I wish folks wouldn't always talk only in terms of Windows...

There's other platforms that are heavily used nowadays; OS X, Linux ditros etc.

Modified by jalyst

Bones42 1 solutions 3 answers

If you're using linux you should be able to find it yourself.

jalyst 0 solutions 24 answers

Of course... but that's beside the point being made.

abePdIta 1 solutions 2 answers

Chosen Solution

In Linux you will find dictionaries in /usr/lib/firefox/dictionaries. You will need root privilegies to delete them.