Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox can't establish a connection to the server at w1.buysub.com. It may be busy, etc....


I get message when I try to update a magazine subscription. I've tried with another browser but still no luck. Norton says it isn't them that's blocking it.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Google Update
  • 5.1.10411.0
  • Picasa plugin
  • GEPlugin
  • DivX VOD Helper Plug-in
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Reader Library Helper Plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications


  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

That page doesn't have useful content or links to another web page.

Which page are you trying to open when you get this error message?

In case you are using a bookmark to a specific page, try to go to the main home page of that site and navigate from there to the desired page.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Question owner

That site manages various magazine subscriptions. When updating info, you will be directed there. I've tried their main page with no luck. My laptop and tablet can get there with no problem but I get shut out while using the desktop. I don't think it's Firefox that's blocking it because, I can't get there with IE either. It may be a windows setting but I can't find anything anywhere in a search.

  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

You can try to reset (power off/on) the router.

Question owner

Thank you but neither worked. I get the same message in safe mode in both Firefox and IE.