X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Completely disable "this plugin is vulnerable and should be updated" page.

Posted

Is there a way to either completely disable this check, or allow a global pass for all websites?

I am aware that I can add individual websites by clicking the icon in the location bar and telling it to always load plugins to that particular site, however for the particular project I am configuring firefox for this is unfortunately not an option - if I can't turn this off I will need to look into other browser options which would be an incredible pain as right now the setup is perfected minus this one point.

I have had a look in the about:permissions page and the only option there for Plugins is 'Allow' or 'Always ask'. I have this set to allow but clearly that the above warning is not influenced by this.

Chosen solution

you can toggle the preference described here: http://kb.mozillazine.org/Extensions.blocklist.enabled (the article is a bit outdated - the blocklist is now not only used for malicious extensions but also to disable vulnerable plugins & crashy graphic drivers).

Read this answer in context 11

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2048 solutions 8914 answers

Chosen Solution

you can toggle the preference described here: http://kb.mozillazine.org/Extensions.blocklist.enabled (the article is a bit outdated - the blocklist is now not only used for malicious extensions but also to disable vulnerable plugins & crashy graphic drivers).

Question owner

Thankyou, this worked perfectly :).

jonzadamonza 0 solutions 1 answers

Hello! I'm just a dumb guy, not a coder, not technical, never edited browser settings or anything like that, who does not want to update his flash version. Can someone please post a step-by-step guide to disabling the message "this plugin is vulnerable and should be updated"? I did not understand what I am supposed to do! How do I toggle the preference here? http://kb.mozillazine.org/Extensions.blocklist.enabled Where do I "toggle a preference"? How do I do it? Please help! Step by step please! Much appreciated

philipp
  • Top 10 Contributor
  • Moderator
2048 solutions 8914 answers

hello, if you're not sure what you're doing, you certainly shouldn't fiddle with this setting.

to address the core of the issue, please update firefox to its latest version (19 at the moment) & keep the flash plugin updated (either use the latest version 11 or 10.3). outdated plugins & browsers are the #1 infection vector on the web, so don't put the integrity of your system and your personal data on it at risk!

Update Firefox to the latest version

https://www.adobe.com/products/flashplayer/distribution3.html

Question owner

EDIT: Double post got moved to helpful so I'll add the info back

Madperson is very correct here - that warning is there to help you and shouldn't be ignored.

I posed this question because I am an IT Professional and was creating a browser installation for a very specific purpose and I needed that setting disabled. As a non-technical home user you should always keep your plugins and addons up to date, especially flash as exploits on it are very commonly used for malicious purposes.

When you install flash it should ask if you would like it to automatically update itself - I highly recommend making use of this feature as you can then just forget about it and your computer will keep it up to date, effectively meaning you won't ever see the warning.

Modified by sparcrypt

Question owner

Madperson is very correct here - that warning is there to help you and shouldn't be ignored.

I posed this question because I am an IT Professional and was creating a browser installation for a very specific purpose and I needed that setting disabled. As a non-technical home user you should always keep your plugins and addons up to date, especially flash as exploits on it are very commonly used for malicious purposes.

When you install flash it should ask if you would like it to automatically update itself - I highly recommend making use of this feature as you can then just forget about it and your computer will keep it up to date, effectively meaning you won't ever see the warning.

tvtoms 0 solutions 2 answers

Helpful Reply

I'll offer a reason why someone would not want to update Flash in particular, in this case it's me, and the reason is simple. Updates after 11.1.102.63 don't function in full screen mode on my 1.4ghz Celeron powered, Windows XP Media Center version 2002 w/service pack 3 computer.

Get a new computer you say? Not in the budget. You're at risk you say? Yep.

It's a shame that Flash isn't backwards compatible to this poor computers heyday. I always tell Flash NO never update, but now Firefox is forcing Flash to be disabled against my wishes and causing me to click on everything Flash if I want it to run. In one sense I don't mind since it's like a built in ad blocker I guess. In another it's quite annoying and I simply want an option to tell Firefox "Yes, I know that. Do as I say anyway."

Modified by tvtoms

philipp
  • Top 10 Contributor
  • Moderator
2048 solutions 8914 answers

hello tvtoms, you can use the latest version of the 10.3 branch of the plugin instead, which has received all security updates and isn't flagged as being insecure: http://www.adobe.com/uk/products/flashplayer/distribution3.html

tvtoms 0 solutions 2 answers

I don't know how you can be sure that will work when I spent many hours going back one release at a time until I found the latest version that worked with my particular computer. But perhaps one day when I have time to work on that old computer I'll try it, so thanks.

dsaur 0 solutions 1 answers

Helpful Reply

Aside from the unhelpful responses for the non-tech savvy.

  1. In your address bar type: about:config
  2. Agree to void your warranty
  3. Right-click anywhere on the list below and select New > Boolean
  4. Copy-paste this phrase into preference name: extensions.blocklist.enabled
  5. The variable should be set to false by default, if it isn't on the list, double click it until it is.
  6. Stuff will work now and I can read PDFs because I don't want to reinstall SumatraPDF all the time.
Dieselmann 0 solutions 2 answers

My wish to stop the 'vulnerable plug in' is temporary and centers on the fact that I cannot get the new Flash update to freakin' install....keeps hanging at 95%. I'm working thru it but in the meantime I want Firefox to just stop harassing me. When I get it sorted out I should simply delete extensions.blocklist.enabled ...correct?