X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Plug-in checker does crash Firefox

Posted

Ever since Firefox 18.0.1 I can not do the automatic check of plug ins. I go to the Add On Manager, click on "Check if your plug ins are up to date" on the left upper corner and then Firefox freezes. Getting a "This program is not responding" message. I can do the check for updates on plugins but I can not go to the pages where the add ons are checked.

Modified by meegja

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Foxit Reader Plug-In For Firefox and Netscape
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tobbi
  • Moderator
67 solutions 450 answers

Mozilla is having problems with the plugin check page right now. I suggest you wait until those issues are resolved.

Add-ons are checked online, you simply go to Tools > Add-ons, click the gear icon and select the check for updates menu item.

Helpful Reply

Wonder why they do not put a warning there? That page is still crashing Firefox (just did try it) but there is no warning or whatever. Why keep it live when they *know* there are problems with it?

Tobbi
  • Moderator
67 solutions 450 answers

Does it still hang?

If so, please try safe mode?

How to start Firefox in Safe Mode

Question owner

Okay, just tried safe mode but it is indeed still not good: it will go to the page but then Firefox completely freezes. The green spinning circle will come up but then the freezes. Page is loading the blue background ... and then it freezes.

Tobbi
  • Moderator
67 solutions 450 answers

Disable one plug-in at a time, then try again. It could be that the way the pluginchecker calls a plugin is invalid.

Go to Tools > Add-ons > Plugins. Then click one plug-in and click the Disable button.

Helpful Reply

Okay, found it! Problem is caused by the Java Deployment Toolkit 7.0.130.20 (10.13.2.20). The Java Platform SE 7 U13 10.13.2.20 plug in works just fine. But why does it crashes in safemode then? Or are plugins loaded in safe mode but add ons are not?

Tobbi
  • Moderator
67 solutions 450 answers

Yes, plugins are not disabled in Safe Mode. They can only be disabled manually.

It might be worth filing a bug report against Plugins for this issue. Or you can wait until Oracle releases an update and see if this fixes it!