X
Tap here to go to the mobile version of the site.

Support Forum

Does Mozilla support 128-bit encryption?

Posted

To use IRS Business Services Online (http://www.socialsecurity.gov/employer/bsohbnew.htm), 128-bit encryption is needed. They say:

"To determine whether your browser supports 128-bit encryption, select Help/About from your browser menu. Most browsers will display the phrase ?128-bit encryption? or "128-bit cipher strength.? If you are unsure whether your browser supports 128-bit encryption, contact the software company that developed the browser."

But I can't seem to find this information on the about page or in online articles about encryption. Would you please help?

To use IRS Business Services Online (http://www.socialsecurity.gov/employer/bsohbnew.htm), 128-bit encryption is needed. They say: "To determine whether your browser supports 128-bit encryption, select Help/About from your browser menu. Most browsers will display the phrase ?128-bit encryption? or "128-bit cipher strength.? If you are unsure whether your browser supports 128-bit encryption, contact the software company that developed the browser." But I can't seem to find this information on the about page or in online articles about encryption. Would you please help?

Chosen solution

Firefox will match the level of encryption the website uses, and Firefox is capable of higher encryption than 128-bit (256-bit if that is what the website uses).

It depends on which order the server offers. If the server offers 128 bit with a higher priority that 256 bit then Firefox will only select 256 bit if you would disable the 128 bit ciphers.

See also https://www.fortify.net/cgi/ssl_2.pl

Read this answer in context 11

Additional System Details

Installed Plug-ins

  • Citrix Online App Detector Plugin
  • Shockwave Flash 11.5 r502
  • WebViewer Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 4.1.10329.0
  • Intel WebAPI Updater - Installs and updates Intel WebAPIs
  • Inte IPT Web API
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Swarnava Sengupta 480 solutions 3191 answers

Chosen Solution

Firefox will match the level of encryption the website uses, and Firefox is capable of higher encryption than 128-bit (256-bit if that is what the website uses).

It depends on which order the server offers. If the server offers 128 bit with a higher priority that 256 bit then Firefox will only select 256 bit if you would disable the 128 bit ciphers.

See also https://www.fortify.net/cgi/ssl_2.pl

Firefox will match the level of encryption the website uses, and Firefox is capable of higher encryption than 128-bit (256-bit if that is what the website uses). It depends on which order the server offers. If the server offers 128 bit with a higher priority that 256 bit then Firefox will only select 256 bit if you would disable the 128 bit ciphers.<br><br> See also https://www.fortify.net/cgi/ssl_2.pl
James
  • Top 25 Contributor
  • Moderator
622 solutions 4657 answers

The Firefox browser uaseragents used to have a U to denote it is a browser with strong encryption and this was removed as of Firefox 4.0. It was removed as it really was not needed anymore anyways for several years now and the browser we know as Firefox supported 128-bit if not 256-bit since it was Phoenix 0.1 back in Sept 2002. Yes the browser was out for two years before the so called November 9 2004 release date.

https://hacks.mozilla.org/2010/09/final-user-agent-string-for-firefox-4/ http://en.wikipedia.org/wiki/User_agent#Encryption_strength_notations

The Firefox browser uaseragents used to have a '''U''' to denote it is a browser with strong encryption and this was removed as of Firefox 4.0. It was removed as it really was not needed anymore anyways for several years now and the browser we know as Firefox supported 128-bit if not 256-bit since it was Phoenix 0.1 back in Sept 2002. Yes the browser was out for two years before the so called November 9 2004 release date. https://hacks.mozilla.org/2010/09/final-user-agent-string-for-firefox-4/ http://en.wikipedia.org/wiki/User_agent#Encryption_strength_notations

Modified by James

dobrdale 0 solutions 1 answers

So how does one tell if 128 bit encryption is being used by my Vista machine using FoxFire 22.0? Is there a notification some where saying the level of encryption being used?

So how does one tell if 128 bit encryption is being used by my Vista machine using FoxFire 22.0? Is there a notification some where saying the level of encryption being used?
cor-el
  • Top 10 Contributor
  • Moderator
11997 solutions 111464 answers

Helpful Reply

Current Firefox releases can't even go below 128 bit, SSL2 that supported this have been removed quite a few releases now (Firefox 8 dropped support for SSL2).

128 bit is the minimum that you can use with Firefox and you can only go higher (e.g. 168 or 256).
128 bit shouldn't be used these days and servers that only support 128 bit should update their software.

Firefox supports AES-256 since 2002, so that is already more than 10 years.

Current Firefox releases can't even go below 128 bit, SSL2 that supported this have been removed quite a few releases now (Firefox 8 dropped support for SSL2). *https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/8 128 bit is the minimum that you can use with Firefox and you can only go higher (e.g. 168 or 256).<br /> 128 bit shouldn't be used these days and servers that only support 128 bit should update their software. Firefox supports AES-256 since 2002, so that is already more than 10 years. * https://www.fortify.net/sslcheck.html