X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I keep getting a "Flash blocker browser settings or extension" error message in Soundcloud after installing fire fox. I have tried flash 11 & 10.3

Posted

I keep getting an error message saying "It looks like you have a flash blocker browser settings or extension. Please enable flash to hear sound" error message come up when I try to play music in Soundcloud. I have just installed Firefox on my laptop and upgraded to the latest Flash player. I then tried down grading to Flash 10.3 but this didn't help. I have been watching programs in iplayer and had no problems there. Please help!

Chosen solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
Read this answer in context 16

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Google Update
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • NPWLPG
  • 3.0.40624.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Chosen Solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Thank you, worked a treat!

pHROZEN_gHOST 0 solutions 6 answers

I have been through this process several times. It sometimes works and sometimes it doesn't. Running in safe mode proves nothing.

Youtube videos work fine. So flash is working. Hosts file is the default one so nothing blocked). No sit blockers etc. all disabled in add-on manager.

Old Soundcloud works fine. Sometimes the new one does. Most of the time it does not.

Switch to IE8 (yuch) and this gets even worse. Old SC works but new one says I need an update and provides a link. I click the link and MS site says I am a;ready running the most up to date browser.

Bottom line... 1) if you use IE, better go to Windows 7 or 8. Otherwise Soundcloud should be avoided. Sure, the old SC still works ... for now.

2) if you use Firefox, roll dem bones and see what ya get. Maybe it will work. Maybe it won't. But it's a pain to have to keep clearing the cache and cookies to fix the one and only site that has this issue with Firefox 18.

3) go to Chrome if you love google. It seems to be OK.

4) ignore soundcloud all together. It's not going to survive long in this mode.