Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my mcafee site advisor is no longer working

  • 5 replies
  • 22 have this problem
  • 6801 views
  • Last reply by CutieT

more options

I have the newest version of mozilla. the mcafee siteadisor browser botton has dissapeared from my mozilla. the green, yellow, and red ticks no longer appear after a web site search. i have re installed mcaffee. still no results.

All Replies (5)

more options

Update your mcafee advisor

enable that in firefox plugin

more options

where can i update the mcafee siteadvisor...

more options

Chosen Solution

more options

I have updated both Firefox (20.0.1) and Site Advisor (3.6.0.126) and enabled in Firefox plugin - still no joy, Site Advisor button (green) in lower right corner will produce a report once a site has been opened, but no indicators on the search result page before site is selected.

A friends computer with same setup (Windows XP) works as advertised. Is there some other non-obvious control somewhere?

Modified by Wil

more options

I have Firefox 22.0 and latest updates for mcAfee but McAfee (see Add-Ons) sez it disabled McAfee site advisor to protect my system from crashes--McAfee tech support 1-866-622-3911 person, "Martin" in India, helped me enable it but but nothing improved: still no search result indicators. So he said to uninstall Firefox and install latest version. I have not tried that cuz it seems to me version 22.0 must be the latest version---am I wrong?