X
Tap here to go to the mobile version of the site.

Support Forum

I have uninstalled Java from my pc but still get nags from Mozilla. How to I stop them?

Posted

Java is completely uninstalled from my computer. I am unable completely remove the plugin from the add on page. It is disabled. I do not have the option in Firefox 15 to remove. It is "grayed out". How can I block those horrible nag messages coming from Mozilla.

Java is completely uninstalled from my computer. I am unable completely remove the plugin from the add on page. It is disabled. I do not have the option in Firefox 15 to remove. It is "grayed out". How can I block those horrible nag messages coming from Mozilla.

Chosen solution

First please update to Firefox 18.0.1 Update Firefox to the latest version

Then read http://www.java.com/en/download/uninstall.jsp to fully uninstall java.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Foxit Reader Plug-In For Firefox and Netscape
  • iTunes Detector Plug-in
  • 5.1.10411.0
  • NPWLPG
  • Picasa plugin
  • Photodex Presenter Plugin 4,50,0,2929
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1245 solutions 8211 answers

Chosen Solution

First please update to Firefox 18.0.1 Update Firefox to the latest version

Then read http://www.java.com/en/download/uninstall.jsp to fully uninstall java.

First please update to Firefox 18.0.1 [[Update Firefox to the latest version]] Then read http://www.java.com/en/download/uninstall.jsp to fully uninstall java.

Question owner

Updating to the newest version stopped the nag screen so I am satisfied.

I still have Java Deployment Toolkit showing as a disabled plugin even though there is no Java listed in the Control Panel list of programs or anywhere on my computer,. I guess if I completely deleted the profile folder it would go away but I probably will just let sleeping dogs lie.
Updating to the newest version stopped the nag screen so I am satisfied. I still have Java Deployment Toolkit showing as a disabled plugin even though there is no Java listed in the Control Panel list of programs or anywhere on my computer,. I guess if I completely deleted the profile folder it would go away but I probably will just let sleeping dogs lie.
cor-el
  • Top 10 Contributor
  • Moderator
12489 solutions 115249 answers

Helpful Reply

You can set the plugin.expose_full_path pref to true on the about:config page to see the full path of plugins on the about:plugins page.

It is best not to leave that pref set to true as it exposes that full path to web servers via the navigator.plugins object, so reset that pref to false after you are done with the about:plugins page.

See "Manually uninstalling a plugin":

You can set the plugin.expose_full_path pref to true on the about:config page to see the full path of plugins on the about:plugins page. *http://kb.mozillazine.org/Issues_related_to_plugins#Identifying_installed_plugins It is best not to leave that pref set to true as it exposes that full path to web servers via the navigator.plugins object, so reset that pref to false after you are done with the about:plugins page. See "Manually uninstalling a plugin": *https://support.mozilla.org/kb/Troubleshooting+plugins

Question owner

Your suggestion worked and I manually removed the Java Deployment Toolkit reference. I had tried this before but unsuccessfully. Your advice was clear and easy to follow. Thank you. I did have to "enable" the plugin first and reboot computer twice.

Your suggestion worked and I manually removed the Java Deployment Toolkit reference. I had tried this before but unsuccessfully. Your advice was clear and easy to follow. Thank you. I did have to "enable" the plugin first and reboot computer twice.