X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I am Unable to Type or use Keyboard in Firefox 18.0 anywhere including URL bar and Search Bar. how should rectify this?

Posted

I am unable to type anything or use keyboard to type in Firefox. I am using Firefox 18.0 installed on Windows 7. I am able to Paste into the URL bar and also the Search bar but absolutely not able to type in it. I have already tried the "reset" option but still unable to type. Also tried Firefox in safe mode with disabled addons but still unable to type. Installed a fresh copy of firefox after uninstalling Firefox and deleting the old folder "Mozilla Firefox" from windows. but still unable to type. Please tell me a solution to this.

Chosen solution

Did you try to reboot the computer?

It is possible that you have switched the keyboard layout by accident to one that doesn't work in Firefox.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application

Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

More Information

{
"application": {
"name": "Firefox",
"version": "18.0",
"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0",
"supportURL": "http://support.mozilla.org/1/firefox/18.0/WINNT/en-US/"
},
"modifiedPreferences": {
"browser.cache.disk.capacity": 358400,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size.use_old_max": false,
"browser.cache.disk.smart_size_cached_value": 358400,
"browser.places.smartBookmarksVersion": 4,
"browser.startup.homepage_override.buildID": "20130104151925",
"browser.startup.homepage_override.mstone": "18.0",
"extensions.lastAppVersion": "18.0",
"network.cookie.prefsMigrated": true,
"places.history.expiration.transient_current_max_pages": 103718,
"privacy.sanitize.migrateFx3Prefs": true
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 1,
"windowLayerManagerType": "Direct3D 9",
"adapterDescription": "ATI Mobility Radeon HD 5450 ",
"adapterVendorID": "0x1002",
"adapterDeviceID": "0x68e0",
"adapterRAM": "1024",
"adapterDrivers": "atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64",
"driverVersion": "8.683.2.1000",
"driverDate": "1-18-2010",
"adapterDescription2": "",
"adapterVendorID2": "",
"adapterDeviceID2": "",
"adapterRAM2": "",
"adapterDrivers2": "",
"driverVersion2": "",
"driverDate2": "",
"isGPU2Active": false,
"direct2DEnabled": false,
"directWriteEnabled": false,
"directWriteVersion": "6.1.7601.17789",
"direct2DEnabledMessage": [
"tryNewerDriver",
"10.6"
],
"webglRenderer": "Google Inc. -- ANGLE (ATI Mobility Radeon HD 5450 )",
"info": {
"AzureCanvasBackend": "cairo",
"AzureFallbackCanvasBackend": "none",
"AzureContentBackend": "none"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.9.4",
"version": "4.9.4"
},
"NSS": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSSSL": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
}
},
"extensions": [
{
"name": "Anti-Banner",
"version": "13.0.1.4250",
"isActive": false,
"id": "anti_banner@kaspersky.com"
},
{
"name": "Content Blocker",
"version": "13.0.1.4250",
"isActive": false,
"id": "content_blocker@kaspersky.com"
},
{
"name": "DivX Plus Web Player HTML5 <video>",
"version": "2.1.2.145",
"isActive": false,
"id": "{23fcfd51-4958-4f00-80a3-ae97e717ed8b}"
},
{
"name": "Kaspersky URL Advisor",
"version": "13.0.1.4250",
"isActive": false,
"id": "url_advisor@kaspersky.com"
},
{
"name": "Safe Money",
"version": "13.0.1.4250",
"isActive": false,
"id": "online_banking@kaspersky.com"
},
{
"name": "Virtual Keyboard",
"version": "13.0.1.4250",
"isActive": false,
"id": "virtual_keyboard@kaspersky.com"
}
]
}

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

As previously written in the question details, I have already tried the "Reset Firefox" and it does not help. Still unable to type anywhere in Firefox or use the keyboard.

iamjayakumars
  • Top 10 Contributor
415 solutions 4927 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Chosen Solution

Did you try to reboot the computer?

It is possible that you have switched the keyboard layout by accident to one that doesn't work in Firefox.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application

Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

Question owner

iamjayakumars, As already mentioned in the question details, I have also tried the "Safe Mode" option. still unable to type in the Safe Mode.

Modified by papillon13

Question owner

To Cor-el, I did reboot the computer. but it did not help the first two reboots. but third time worked like a charm. before the third time and I also disabled the Safe Money option in Kaspersky Internet Security 2013. Seemed to work. thanks

sebert 0 solutions 1 answers

I also have problems with typing. Whenever I want to write into a field (e.g. to write this post) I have to click first into the search bar field, url address field, or to another tab, and after that I am able to write into the desired field. This is in particular annoying if you write a long text and you want to move the cursor with the mouse to another position or if you use Google Docs and want click and to write into specific cells.

I have a Mac with current Mac OS X 10.7 and I - for sure - don't change any settings and I know at least two other persons that have similar problems. Is there a possibility to get the download link to the previous version < 18.0 where I don't observe any of these problems because with the current version I cannot work anymore as I have to work a lot with Google Docs.

Best, Sandra

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

JH 0 solutions 2 answers

Same problem here. Anyone able to resolve the issue?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Helpful Reply

Some have reported that this procedures helped:

Press Fn+Windows Key and then click in the text area to see if this works.
You may have to repeat this a few times.

JH 0 solutions 2 answers

Helpful Reply

I'm not on a laptop so I don't have a FN key. But on my desktop F9 + Windows key appears to have resolved the issue for me. Thanks for the help!