X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does the Sony store website for the US (http://store.sony.com) not work properly on Firefox?

Posted

A lot of page elements do not work properly on that website when you access it via Firefox. For example, bars that are supposed to be interactive and can be slid from right to left for viewing an attached panel of options do not slide. Buttons that are supposed to change the colour of the laptop preview images do not work. And a lot of other buttons supposed to link you to another page or function as selection buttons do not work as such and simply redirect you to the top of that same page.

All of these problems are nonexistent when you access the website with IE.

Chosen solution

Here is the screenshot. I am going to try the Safe mode now, and shall report back if it works.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • VLC media player Web Plugin 2.0.2
  • Yahoo Application State Plugin version 1.0.0.7
  • Unity Player 3.4.1f5
  • iTunes Detector Plug-in
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96771 answers

Helpful Reply

Can you give more details about which buttons aren't working?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

Chosen Solution

Here is the screenshot. I am going to try the Safe mode now, and shall report back if it works.

Question owner

Update: Apparently, it works in Safe Mode. Now if only I could figure out how to make it work out of it, too. Thank you so very much for the help.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96771 answers

That can happen if JavaScript is blocked.