X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I unblock Flash?

Posted

I keep getting messages that the Flash plug-in is being blocked. I have the most up-to-date version of Flash available. I've so far been able to solve this problem by closing Firefox, deleting the blocklist.xml and pluginreg.dat files and then restarting Firefox. Is there anyway to solve this problem without having to manually delete those two files every single time?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • VLC media player Web Plugin 2.0.2
  • Google Update
  • np-mswmp
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Foxit Reader Plug-In For Firefox and Netscape
  • 4.1.10329.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8035 answers

Sorry no time to investigate now, but as no one else is answering I will give a quick response

  • Flash should not be blocked (but in some cases it may not be the best option to use the latest version, and note disabling protected mode may help )
  • it follows that I do not see that the blocklist should be a problem
  • look on https://addons.mozilla.org/en-US/firefox/blocked/ it is not listed as far as i can see.

There is a new click to play feature that has caused problems. (not sure where current documentation is ,but it started with https://wiki.mozilla.org/Opt-in_activation_for_plugins )

It would help if you could give more information about what you see please copy any error messages and give screenshots or anything that shows the problem.