X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My centre search bar will not work, I type in it then hit search or enter but no response, it does absolutely nothing. What is wrong and how do i fix?

Posted

when i start up firefox it loads as normal. I have the main web search bar (top left) and the google search bar (top right) then there is also the mozilla logo and third search bar just below it in the centre of the screen. This was my main bar as i liked the feature of left clicking in it and it instantly displaying my last searches and choosing from them what i wanted to do. Now it has just stopped working, it has none of my last searches stored and whatever i type in it doesn't matter anyway as it just doesn't do anything, it is totally non responsive. help please?

Chosen solution

You can check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

I tried uninstalling Firefox and reinstalling again but it didn't help.
Went through the menu hoping I'd accidentally turned it off somehow but this is obviously not possible to do as you will know. Now, so do I.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello Painterman98, please try the following steps in order to restore the search function on the default homepage:

  1. go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
  2. then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
  3. restart firefox
cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96840 answers

Chosen Solution

You can check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

Modified by cor-el

Helpful Reply

It works again, thanks. It was only a small thing but so annoying. Do you know why this happened so I can maybe avoid it in future?

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96840 answers

What was needed to fix the problem in your case?

There is usually security software or an extension or malware involved if pref settings change unintentionally without you doing anything.