X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

iCloud website has massive usability issues - is it compatible?

Posted

I cannot use iCloud.com in Firefox at all. Starting from the login prompt there are many issues. From the e-mail field, you cannot use Tab to move to password field, only mouse. From the password field, you do not see the eye icon to show password (IE only?), and cannot use the clickable arrow to continue, only enter. Once signed in, you can click any of the icons such as Mail or Calender, but not the Help "?" in the corner. From inside any and all of the services (Mail, Reminders, etc) you lose complete control of any of the buttons, options, scrolling menus - everything. The back button on the website (iCloud icon) does not work, forcing you to use the browser back button. Clicking on another service presents the same issues - absolutely nothing is usable, clickable, or scrollable. It seems like Javascript has completely failed - though that is an uneducated guess in the dark.

This occurs on Windows 8 64bit and Firefox 18/19 Beta. I have gone through many troubleshooting steps and it has made no difference in the slightest. I have cleared all caches several times, from inside Firefox and through 3rd party utilities. Tested in Safe Mode to no avail. Manually removed several add-ons, checked all add-ons are fully up-to-date (as always), and reset all Firefox settings to default (except Hardware Acceleration that causes graphics issues in 8 - does not help iCloud.com enabled, though). It works fully in all other browsers with similar add-ons without issue. I have not done a full, complete reset and profile removal - that is next. However, I have a gut feeling that is not the issue at hand. I performed a clean install of Windows 8 and a clean install of Firefox less than 2 weeks ago.

Chosen solution

I may have be hasty in choosing a solution - I am unsure if this will work for everyone. I have not been able to recreate this issue anymore in Firefox 18.0.1 or 19 Beta 3. It was either fixed in 18.0.1 or was an issue with 3rd party software. The thing is, I'm the only user on my computer and I know EXACTLY what was installed or updated. There hasn't been any Windows Updates since January's Patch Tuesday, and I've tested several times since then with no luck (until Beta 3).

Downgrading from Beta 3 to 18.0.1 I did not do a clean install. I always did a clean install with fully removed profile and everything in previous tests, and it did not help the issue.

Basically, I'm completely stumped as to why it suddenly started working when Beta 3 is the only thing that's changed (I checked Windows Updates and restore points for any installs - nothing has changed since Patch Tuesday - I did not update any plugins for Firefox, but they never affected this bug active or disabled anyway). It is strange that downgrading does not reintroduce the bug, as I did previously have it in 18.0.1. So far, all I know is it does work in 19 Beta 3 again.

This could have been something simply fixed on Apple's website as well. It would explain why it works in 18 and 19 suddenly - when nothing else ever made a lick of difference. Hopefully someone else can confirm that is has started working for them as well!

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • The QuickTime Plugin
  • Nitro PDF plugin for Firefox and Chrome
  • Picasa plugin
  • iTunes Detector Plug-in
  • NPWLPG
  • 4.1.10329.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Application Basics
Name
Firefox
Version
19.0
User Agent
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
DownloadHelper
4.9.13
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Print Edit
8.9
true
printedit@DW-dev
SmoothWheel (AMO)
0.45.6.20100202.1
true
{5F590AA2-1221-4113-A6F4-A4BB62414FAC}
WOT
20120926
true
{a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.privatebrowsing.dont_prompt_on_enter
true
browser.startup.homepage_override.buildID
20130109111322
browser.startup.homepage_override.mstone
19.0
dom.mozApps.used
true
extensions.lastAppVersion
19.0
gfx.direct2d.disabled
true
layers.acceleration.disabled
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358017940
places.history.expiration.transient_current_max_pages
104858
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.cpd.offlineApps
true
privacy.cpd.siteSettings
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
Mobile Intel(R) 4 Series Express Chipset Family (Microsoft Corporation - WDDM 1.1)
Adapter Drivers
igdumd64 igd10umd64 igdumd32 igd10umd32
Adapter RAM
Unknown
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200
Device ID
0x2a42
DirectWrite Enabled
false (6.2.9200.16433)
Driver Date
3-24-2012
Driver Version
8.15.10.2702
GPU #2 Active
false
GPU Accelerated Windows
0/1 Basic
Vendor ID
0x8086
WebGL Renderer
Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family (Microsoft Corporation - WDDM 1.1))
AzureCanvasBackend
cairo
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
true
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4 Beta
4.9.4 Beta
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

RedlandHEO 0 solutions 2 answers

My Firefox updated to 18.0.1 and my iCloud works fine as it should now.

Tomel 0 solutions 3 answers

Just in case you didn't see my last post on the bug report . . .

iCloud now works for me again also. What's strange is that I didn't change anything. I didn't downgrade, I didn't upgrade (still using Firefox Version 18.0), I didn't make any system changes whatsoever. It just started working again for no obvious reason.

rvs007 0 solutions 5 answers

Since everyone subscribed to this thread uses Firefox with iCloud, perhaps I can ask an off-topic question.

For the longest time, I've noticed that when I'm in the mail app of the iCloud.com website, and viewing an email that has HTML content and it's showing in the right-hand side window, the scrolling is extremely slow when using the scroll-wheel of my mouse. I don't notice this when I use Chrome or IE, it's only in Firefox.

Does anyone else have this problem? Is there a fix for it?

Again, I apologize for taking this thread off-topic.

Question owner

Just so anyone who doesn't know - you can unsubscribe from e-mail updates on the top right hand side of the page!

I have no problem with your question though, and I've had very similar issues on some computers. Most of the time, the scrolling gets worse and jerkier the older the computer is. It also seems like certain graphics cards just don't get any love from Firefox. There's a couple of quick things to try - the first is simply disable smooth scrolling from Options>Advanced>Smooth Scrolling. It has been on by default for a while, but if you have an older profile it may have never turned on in the first place. If it's on, try it with it off. If it's off, it may help with it on.

Hardware Acceleration may also help or hurt some pages, depending again on the graphics and processing power of the computer. This option requires a browser restart to disable or enable. It causes me a lot of graphics glitches in the UI on Windows 8 (not 7, though) with older Intel Integrated Graphics. It may or may not affect scrolling at all, but it's something to try.

Lastly, this should definitely help if the smooth scrolling option in Firefox just isn't enough or isn't quite right. It's an add-on called SmoothWheel - http://goo.gl/harzB - It is pretty reliable for me, and it is almost infinitely customizable. It can really smooth out (no pun intended) the scrolling effects on older hardware, or just let you tweak it for your preferences. It does not work on all pages (it has self checks to maximize effectiveness and compatibility) but a huge majority are vastly improved. I typically just use the default settings myself. It recommends to leave Smooth Scroll enabled in Firefox - that option will kick in on pages where SmoothWheel is not compatible.

Hope this helps! If anyone is bothered by these updates - please unsubscribe! The iCloud issue does seem to have been fixed on Apple's end so there is not much more to add to it.

rvs007 0 solutions 5 answers

Thanks for replying djdisconess, I've tried disabling the various options but didn't change anything. I also tried the SmoothScroll add-on but that didn't help either.

Just to clarify, the scrolling of the email message headers in the middle column of the mail app is unaffected. It scrolls at a speed that's consistent with scroll speeds for other webpages. However, when I hover on the right-hand preview pane and scroll, it becomes extremely slow, where each rotation of the scroll wheel would only scroll about 1/10 of the page compared with the normal scroll speed. I don't think it is related to the computer as this happens at work & at home (with my work computer being much faster).

It feels like the scroll rate for the right-hand preview window is wrong compared with the scroll rate for other parts of the mail app windows, and for other webpages in general.

Hope this describes my problem better.

Question owner

I see what you mean now. I was thinking more of a jerky slow - this is a steady scroll just far below the normal speed. I appear to have this issue on Windows 8 as well. Works as expected in Chrome. It seems more like an issue with Firefox or Windows misinterpreting the "amount" of scroll to use.

By setting my mouse to scroll '20' lines at a time instead of the default 3, it appears to scroll at a normal expected speed (everything else scrolls really fast). Turning the rate down presents the problem again. This definitely means (to me, anyway) that it is a bug somewhere in the scrolling that is controlled by Windows, or that Firefox is somehow misinterpreting the scroll lines. This is a workaround of sorts - if you use SmoothWheel and turn scroll lines higher (20 was my first guess) - but any other browser or program will scroll ridiculously fast, so it's not very practical.

Basically, it seems like a bug in Firefox's mouse controls (or Windows) and not specifically related to iCloud. It could just be presenting on iCloud because of a certain way they write the page or just a perfect combination of circumstances. I'm totally unsure of how to actually fix it though.

I'll see if I can find a Bugzilla report or anything like that, but if you want to make another support page thingy or anything send me a link and I'll subscribe to it. My personal e-mail is my username at the most popular e-mail client that starts with a G.com