X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Change Mozilla Firefox display

Posted

I am using Mozilla Firefox 18.0. on a Windows 7 computer. The Mozilla page is really inefficiently set up. I have a screen shot but there doesn't seem to be any way to post it in this forum. [From help:You now have a screenshot that you can add to your forum question by clicking the Browse button in the Post a Reply box. However, no 'browse' button on this page. :-(] I will describe, line-by-line, what I see on my screen for this page:

[Mozilla logo]Ask a Question|Mozilla Support-Mozilla Firefox File Edit View History Bookmarks Tool Help [A line with the current URL on the left side and a search bar on the right side] A blank blue line [Headings for each of the tabs I currently have open]

I don't need the first line or the fourth line. How do I remove them? If you know how to add a screen shot, let me know.

Chosen solution

Brilliant - that worked! Thanks.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Google Update
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG
  • Picasa plugin
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

I bumbled around a bit on the Mozilla help web site but could find nothing that seemed to address this. In your reply, understand that I'm not a computer geek! Thanks for your help.

Question owner

Screen shot below.

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

You can use Customize Firefox controls, buttons and toolbars to remove the toolbars. I think that extra one is the bookmark toolbar. Show or hide the Bookmarks toolbar

Question owner

Thank you for your reply. I have read through each of those links but still have not found the answer to my question. Could you be more specific as to how to remove the first and fourth lines that are displayed in my screen shot?

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

You can't remove the first title bar line that is part of the window frame unless you would hide the menu bar to get the orange Firefox button.

You can select which toolbars to show via View > Toolbars of Firefox > Options if the menu bar is hidden.

Note that current Firefox versions only show the "Tabs on Top" menu entry in the "View > Toolbars" and "Firefox > Options" menu and in toolbar context menus if the tabs aren't in the default position on top.

If the tabs are on top and the menu entry isn't available and you want to move the tabs below the navigation toolbar then you need to flip the browser.tabs.onTop pref to false on the about:config page.

Question owner

Okay, I understand from your reply that I can't get rid of the top line (even though it is, IMHO, completely superfluous).

I didn't quite understand this:

you need to flip the browser.tabs.onTop pref to false on the about:config page.

Could you be more specific as to how I do this? Will that remove the blank fourth line?

ideato
  • Top 25 Contributor
617 solutions 4264 answers

Hello queenmab100, see: about:config, type/find browser.tabs.onTop and double-click on it to make it false.

thanks

Question owner

I read that article but didn't understand any of it.  :-(

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

Helpful Reply

Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.

Use the Search bar at the top of the about:config page to locate preferences more easily (in this case: browser.tabs.onTop)
You can toggle a Boolean pref (i.e values true or false) with a double click on the related line.

  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean

See also:

Question owner

Well, that worked to get my tabs on top, which I like better. Now, if I could only figure out how to reduce the size of that blank area under the address bar (or better yet, eliminate it completely). Screen shot attached. That's expensive real estate on my screen going to waste!  :-)

Thanks for your help.

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Right click it, and uncheck "Bookmarks Toolbar"

Question owner

When I right click the blank area under the address bar (where the current URL appears), the only choices are 'new bookmark', 'new folder', 'new seperator' , 'copy', 'sort by name' and 'properties'. I don't want to get rid of my bookmarks on the left side of the screen, only the blank line above the word 'bookmarks'.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

Helpful Reply

Try to right click empty space on the Tab bar or Menu bar or go to View > Toolbars to hide the Bookmarks Toolbar.

Chosen Solution

Brilliant - that worked! Thanks.