X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Poor text font rendering and display resolution

Posted

While I am a software database developer, I know VERY little about HTML/CSS coding.

After updating to Firefox v18 yesterday, the font text rendering seriously degraded! The resolution now is very poor and fuzzy! IE9's resolution is "perfect."

Both browsers are running on a fresh new custom install of Win7-64 where NO special global display config settings have been made.

Since this problem occurred after the FF v18 upgrade and did NOT exist in IE9, it seems as if this problem is specific to Firefox.

After searching Google for several hours now without finding any intuitive-sounding solution nor knowing what to look for, I have posted this request for help in hopes someone will please kindly reply back with a fix.

PS: Sorry for the duplicate post... Had problems with the first submission due to the Email Registration process.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application Basics
Name
Firefox
Version
18.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.search.update
false
browser.startup.homepage
https://startpage.com/do/mypage.pl?prf=b256186f6dcc9448e8d10b0bea55e53a
browser.startup.homepage_override.buildID
20130104151925
browser.startup.homepage_override.mstone
18.0
browser.tabs.loadInBackground
false
browser.tabs.onTop
false
browser.urlbar.autocomplete.enabled
false
dom.mozApps.used
true
extensions.lastAppVersion
18.0
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1357914093
places.history.enabled
false
places.history.expiration.transient_current_max_pages
104858
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.offlineApps
true
privacy.clearOnShutdown.passwords
true
privacy.clearOnShutdown.siteSettings
true
privacy.cpd.cookies
false
privacy.cpd.offlineApps
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
privacy.sanitize.timeSpan
0
Graphics
Adapter Description
Intel(R) HD Graphics 4000
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM
Unknown
ClearType Parameters
Gamma: 1800 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100
Device ID
0x0162
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
Driver Date
9-26-2012
Driver Version
9.17.10.2867
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 10
Vendor ID
0x8086
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics 4000)
AzureCanvasBackend
direct2d
AzureContentBackend
direct2d
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

qloolp 0 solutions 1 answers

@StratMan55

I have the same problem and I found the solution. It is display driver. You need to update the display driver to fix this problem.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.

Question owner

Thank you for your replies.

Late last week, this [this topic was found], which is where I have posted several replies, test findings and solution.

No one yet has responded to...

"In the Tools / Options / Advanced / General Tab, it was noticed that the FF17 install had the "Use Hardware Acceleration When Available" box checked, which was not recalled being checked when configuring FF18 yesterday. For grins, I unchecked the box, stopped and restarted FF17 and, sure enough, the blasted fuzzy text problem instantly returned. Upon rechecking that config setting box and restarting FF17, the fuzzy text issue went away."

...In order to confirm this finding so that this FF Rookie can learn how best to configure FF18.

Please reply back... Much appreciated. :)

Modified by cor-el

Rusty Jones 0 solutions 5 answers

DISTORTED TEXT * * * * * I also have ATI Mobility Radeon HD 4200 Series, no updated driver available - Turning off Hardware Acceleration made no improvement. Problem began with Firefox 19.0 update!

j3pflynn 0 solutions 4 answers

Did you restart the browser after making the change? I, too, have the Radeon HD4200 chipset and unchecking hardware acceleration, then restarting the browser took care of it. Re-checked and restarted to verify that it came back - it did. Unchecked, restarted and the issue was gone again.

palletboy 0 solutions 1 answers

I'm having the same issue since upgrading - now on FF 20.0.1. It happens during scroll. Odd thing is, it stays that way until something changes to re-render, such as a Control-A (select all) which must force a rerender, then it clears until scrolling again - see attached image.

Any known fix? It's NOT the drivers - it's FF... don't make me use IE.... please....

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

You can also try to uninstall Windows update KB2670838 if you have this update.


marktorrey 0 solutions 2 answers

Same problem, initially on only small sections of text on a page. Mildly annoyed, but have been able to ignore it... until today when it became a full page problem.

The solution to set "gfx.content.azure.enabled" pref to false, and restarting FF 20.0.1 resolved the problem for me.

My "use hardware acceleration when available" option remains checked.

Just my $0.02 worth