X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do i turn off password manager on firefox 18, the option box is ticked but shaded so i can't untick it

Posted

I am prompted every time i visit a site that i enter a password on to save it in firefox 18, it's now getting annoying. I have tried to turn it off, but the box in firefox settings is shaded and won't allow me to turn password manager off, i know i can choose "never for this site" in the settings but with just about every site you go to now requires you to sign in it is really getting on my nerves. if this can't be resolved i may reluctantly have to change browser.

Chosen solution

The instructions at

http://community.norton.com/t5/Norton-Internet-Security-Norton/Firefox-Bug-Norton-add-ons-trigger-Firefox-18-password-manager/td-p/888683

explain how to change the N360 setting to resolve this problem.

Tested and works. No more unwanted prompts.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Google Update
  • 5.1.10411.0
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Macromedia Authorware Web Player Netscape plug-in, version 2004

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello, do you use a norton security product by any chance? it might interfere with the firefox password management...

http://community.norton.com/t5/Norton-Toolbar-Norton-Identity/NIS-2013-Norton-Toolbar-Unselects-Firefox-Remember-Passwords/td-p/836598

otherwise you could try to reset firefox and see if this makes a difference (this will keep your bookmarks and passwords): Reset Firefox – easily fix most problems

Question owner

yes i use norton 360 and i use idenity safe, so have no requirements for firefox password management, this is the first firefox i have had this problem with it's never been a problem with any other firefox below firefox 18. i have always used norten 360

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"
insevin 0 solutions 9 answers

Helpful Reply

Same problem, I want firefox password manager GONE.

Question owner

I do use "custom settings for history" and have never used "Always use private browsing mode"

I haven't changed anything all I did was update firefox from firefox 17 to firefox 18 and all of a sudden this firefox password manager keeps popping up and in settings the box is shaded and wont let me turn it off, if its not sorted in a week or so im changing browser its doing my head in

Noah_SUMO
  • Moderator
50 solutions 303 answers

Very understandable, Steven. My guess is that a addon is causing this. And rather than have you type the names of all your addons, which would very annoying if you have a lot. There's a way you can copy all the information and paste it here.

Please read this article and follow the steps there:

Then after having copied the information, paste it into this thread so I can try to see if one of the addons may be causing this. My guess is a password related addon.

insevin 0 solutions 9 answers

I've found out Norton add-ons are doing it for me, but only since FF18. So apparently something Mozilla did is making third party add-ons bug out. Funny that we went from v3 to v18 in such a short time and most of these updates add support for things that only >0.01% of users actually use and have the side effects of making our favorite add-ons break.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello insevin, in this case please report the issue to norton's support since they are the only ones who can fix bugs or make necessary adjustments in their addon. thank you...

insevin 0 solutions 9 answers

Ha, sure, it will fall to Norton to fix Mozilla's problems. I already have, I'm sure they will fix it soon.

Question owner

Application Basics

       Name
       Firefox
       Version
       18.0
       User Agent
       Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0
       Build Configuration
         about:buildconfig
 Extensions
       Name
       Version
       Enabled
       ID
       British English Dictionary
       1.19.1
       true
       en-GB@dictionaries.addons.mozilla.org
       Java Console
       6.0.35
       true
       {CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}
       Java Console
       6.0.37
       true
       {CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}
       Norton Toolbar
       2012.5.10.1
       true
       {2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
       Norton Vulnerability Protection
       11.1.1.5 - 2
       true
       {BBDA0591-3099-440a-AA10-41764D9DB4DB}
       Java Console
       6.0.33
       false
       {CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA}
       Microsoft .NET Framework Assistant
       0.0.0
       false
       {20a82645-c095-46ed-80e3-08825760534b}

Modified by Noah_SUMO

Noah_SUMO
  • Moderator
50 solutions 303 answers

Steven, to fix this problem you're going to need to disable the Norton Toolbar addon.

Go to: Firefox button > Add-ons

Then click on Extensions then click the Disable button on the Norton Toolbar addon. Close Firefox. Open Firefox again and you should now be able to turn off the password manager in Firefox settings.

This is a bug in their software that they've known about since August September 2012. Norton is known to be extremely slow in fixing situations like this so I wouldn't expect a fix anytime soon.

Modified by Noah_SUMO

insevin 0 solutions 9 answers

Jumping in here again. Nope, its something Mozilla did in FF18 that affected all Norton users. It wasn't caused by Norton and since its only been a few days as a widespread problem affecting all Norton users, not since August, I'm not too concerned about the speed of a patch yet. I'm sure it will release sooner than Mozilla releases it's updates.

Suggesting to us to disable Norton is being a sarcastic arrogant jerk. "Your Norton Finger itches? Cut it off, the hand heals too slowly, Mozilla Body matters more. Don't bother looking for a solution your finger doesn't matter to me or anyone whose opinion matters therefore nothing will ever be solved."

Noah_SUMO
  • Moderator
50 solutions 303 answers

If you bothered to read this support thread at the Norton forums:
http://community.norton.com/t5/Norton-Toolbar-Norton-Identity/NIS-2013-Norton-Toolbar-Unselects-Firefox-Remember-Passwords/td-p/836598

You would see where it's specifically mentioned that someone saw the exact same problem and reported it on 9-18-2012 with Firefox 15. I was a month off.

Here's the exact link to that report:
http://community.norton.com/t5/Norton-Toolbar-Norton-Identity/360-PE-v20-x-amp-FF15-password-management/td-p/807834

So regardless of when you first encountered this issue, this has been a ongoing issue.

A Norton team member responded they'd look into this on 11-2-2012 (2 1/2 months ago) and has made no replies or status updates since. (Link)

Also I only advised Steven to disable it. It's up to him to make the choice.

Also I have my own strong opinions of Firefox as well and don't blindly love all the changes they're making. Especially rapid release updates. But in my years of troubleshooting Norton toolbar issues I've seen first hand how slow they are to resolve such issues.

I actually agreed with what you said earlier:
...So apparently something Mozilla did is making third party add-ons bug out. Funny that we went from v3 to v18 in such a short time and most of these updates add support for things that only >0.01% of users actually use and have the side effects of making our favorite add-ons break.

But I don't fully agree in this case since the issue has existed since last year and I've seen loads and loads of problems reported with Norton toolbar over the years causing bugs they'd promise to fix but take months to fix them. That's back when we had the once a year slow release schedule. If it's Mozilla's fault, I expect them to take full responsibility for it and work w/ the Norton company to help them fix it.

I'd suggest you not focus your anger at me. I don't work for Mozilla and these forums are community/volunteer driven.

My only goal is to give Steven the fastest and easiest choice to get around this annoying, frustrating issue regardless of whose fault you believe it is.

unicorn512 1 solutions 1 answers

Chosen Solution

The instructions at

http://community.norton.com/t5/Norton-Internet-Security-Norton/Firefox-Bug-Norton-add-ons-trigger-Firefox-18-password-manager/td-p/888683

explain how to change the N360 setting to resolve this problem.

Tested and works. No more unwanted prompts.

insevin 0 solutions 9 answers

Ok Noah, still waiting on a fix from Mozilla.

Unicorn that is my topic at Norton, ironic isn't it, but still no solution to the Firefox bug.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

even if you continue to repeat it, the issue you're facing is not a firefox bug (disabling the password manager works perfectly well when the addon in question isn't present) and won't be treated as such.

mozilla neither claims that it supports norton's security tools nor does it charge you any money for that - it's the other way round. so this should give you an indication whose job it is to provide a fix...

Helpful Reply

the link that unicorn 512 put on


The instructions at

http://community.norton.com/t5/Norton-Internet-Security-Norton/Firefox-Bug-Norton-add-ons-trigger-Firefox-18-password-manager/td-p/888683

explain how to change the N360 setting to resolve this problem.

Tested and works. No more unwanted prompts. noah turning off norton in firefox is not an option i would just change browser if a solution hadn't of been found. at the moment all working ok

insevin 0 solutions 9 answers

+1 Steven! Congrats, hopefully I will find my solution soon as well.