X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My downloads through Firefox don't actually download - "Open" and "Open containing folder" and greyed out when I right click the downloads in the downloads menu

Posted

I've had this problem for quite a while. The downloads don't actually download. Nothing comes up in my downloads folder (and I've checked where they are supposed to be stored, I am checking the right place). In my downloads popup through the Firefox client, if I right click any download, both "Open" and "Open containing folder" are greyed out. I have tried using both Firefox 18 and the current Nightly client, and have reinstalled multiple times.

Chosen solution

Which security software (firewall, anti-virus) do you have?

If "Open" and "Open Containing Folder" in the right-click context menu in the Download Manager window are grayed then that means that the file is no longer in the original download location and they may have been removed by Anti-virus or cleanup software.

It is possible that anti-virus software is corrupting downloaded files or is otherwise interfering with downloading files.
Try to disable the real-time (live) scanning of files in your anti-virus software temporarily to see if that makes downloading work.

See:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • 0.3
  • Pando Web Plugin
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Raidcall plugin
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

smo 45 solutions 498 answers

Maybe this will look like a "take aspirin" suggestion, but based on experience so far, The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Thanks for the response, but no, it is still the same after using the Reset Firefox feature. It's just such an odd problem since it's persisted through multiple different versions of Firefox and multiple reinstalls...

MR. Garcia 0 solutions 3 answers

Are you sure you didn't install any particular Add-on or Extension ? Check your Add-ons, Extensions and Plugins ... Maybe one of them making this problem for you ...

smo 45 solutions 498 answers

Maybe it has something to do with the download folder and access rights to it. Try changing its location in Options > general.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Chosen Solution

Which security software (firewall, anti-virus) do you have?

If "Open" and "Open Containing Folder" in the right-click context menu in the Download Manager window are grayed then that means that the file is no longer in the original download location and they may have been removed by Anti-virus or cleanup software.

It is possible that anti-virus software is corrupting downloaded files or is otherwise interfering with downloading files.
Try to disable the real-time (live) scanning of files in your anti-virus software temporarily to see if that makes downloading work.

See:

Question owner

I am using Microsoft Security Essentials.

Disabling browser.download.manager.scanWhenDone worked! Thanks so much for your help! :) :)