X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Updated to v18 and default home page search does not work

Posted

I just updated to Firefox 18 and my default Firefox start page does not work. I type in a word and hit 'enter' or click on search and nothing happens. If I use the Google bar no problem.

Chosen solution

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • VLC media player Web Plugin 2.0.2
  • Google Update
  • iTunes Detector Plug-in
  • Foxit Reader Plug-In For Firefox and Netscape
  • 5.1.10411.0
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • GEPlugin
  • NPWLPG
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Thank you so much, all OK now.

bennyhillthebest 0 solutions 1 answers

I found a solution that doesn't require the reset of the browser. In about:config search for browser.aboutHomeSnippets.updateUrl, then delete the saved link of the key. There seems to be some problems with the snipplets, the informations that pop up in the home page of FF. Then, if you are interested in those informations, you can reset the key to the original link, because the snipplets after the first restart are fixed.

cor-el
  • Top 10 Contributor
  • Moderator
10748 solutions 96724 answers

Chosen Solution

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

paulnew 1 solutions 4 answers

I have tried your suggested resolution but it does not work. The mstone values are reset upon startup and the problem still persists. Prefs.js is OK on FF closedown but the Browser.search.homepage_ .... set to 18 is present in pref file after startup. Search on home page still does not work. I do get the new fire fox version tab on startup though.

Any suggestions ?

Modified by paulnew

glnz 2 solutions 17 answers

cor-el's and bennyhillthebest's solutions did not work for me, and I did not want to reset and wipe out all my extensions. Had to switch my start page to www.google.com but would like the Mozilla Firefox Default Home page to work. Any other ideas?

cor-el
  • Top 10 Contributor
  • Moderator
10748 solutions 96724 answers

What is the value of the browser.search.defaultenginename pref?

Do you have a mozilla.cfg file in the Firefox program folder?

glnz 2 solutions 17 answers

Cor-El:

browser.search.defaultenginename has no value

and

there is no mozilla.cfg on my computer.

(I am Win XP Pro SP3 with Firefox 18. I disabled Java today per the recent warnings, but the home page was not working for some time.)

Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10748 solutions 96724 answers

Can you reset that pref via the right-click context menu to the default Google value?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
glnz 2 solutions 17 answers

Cor-El: What means " ... the default Google value? "

Thanks.

glnz 2 solutions 17 answers

Cor-El - Unfortunately, in Safe Mode, the Mozilla Start Page still doesn't work.

cor-el
  • Top 10 Contributor
  • Moderator
10748 solutions 96724 answers

"Google" is the default value of the browser.search.defaultenginename pref, so if you reset the pref via the right-click context menu then you should see a not bold Google setting that shouldn't change after a close and restart of Firefox.
That default search engine should also be installed as one of the search engines for the search bar on the Navigation Toolbar.

Try to delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder to reset the search engines.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

glnz 2 solutions 17 answers

Helpful Reply

Cor-El: Adding Google as the String in browser.search.defaultenginename seems to have done it. No need for other, more complex steps.

Many thanks!

cor-el
  • Top 10 Contributor
  • Moderator
10748 solutions 96724 answers

You're welcome.

BulletProofBody 0 solutions 2 answers

OK, I got up this morning and tried to open Firefox... it opened but nothing came up on the start page, then my Mom called said hers wasnt working either? Ok So I tried to type my start page into the address bar... nothing... then tried to use the google search bar... nothing... Tried to search ANYTHING... nothing... wont do anything.... So now Im typing this on IE, only thing that works right now.... I tried the resets that were suggested... nothing works.... Uninstalled Firefox.... Then tried to reinstall Gets to the page about WHO to put the install under... Admin , user then I click... Nothing... Checked Avast... all running fine.... Just got a call from my Mother-in-Law now... hers aint working either... WHOA what a sh!t storm.... HELPPPPPP

cor-el
  • Top 10 Contributor
  • Moderator
10748 solutions 96724 answers

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

BulletProofBody 0 solutions 2 answers

No, I tured the Anti virus off... Then unistalled Firefox, then tried to reinstall in... Firefox wouldnt reinstall... I rolled my computer back to the OLD firefox... Worked fine. That 18 update just screwed everything up. Wont be updating again for awhile.