X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cookie exceptions spontaneously change.

Posted

On the Privacy tab in Options the check box for Accept cookies from sites is unchecked. I pressed the Exceptions button and added many websites to accept cookies from and clicked Allow for Session on each one. Sometimes I go to a website where I have to sign in with a username and password and the site states that my browser is refusing to accept cookies even though I had added the site to the exception list. When I check the exception list, the status of the exception has changed from Allow for Session to Blocked. I have found several exceptions change on their own from allow to blocked and some even have changed again after I changed them back. What could be causing the exceptions to change and is there some way to make the settings persistent?

Chosen solution

Do you have the network.cookie.blockFutureCookies set to true on the about:config page?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.2 r152

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

Application Basics
Name
Firefox
Version
10.0.2
User Agent
Mozilla/5.0 (Windows NT 5.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
bug489729
1.7
true
bug489729@alice0775
Flashblock
1.5.15.1
true
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
FlashGot
1.5.2
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
Mozilla Archive Format
2.0.8
true
{7f57cf46-4467-4c2d-adfa-0cba7c507e54}
NoScript
2.6.4.2
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
RefControl
0.8.16
true
{455D905A-D37C-4643-A9E2-F6FEFAA0424A}
UnMHT
5.7.7
true
{f759ca51-3a91-4dd1-ae78-9db5eee9ebf0}
User Agent Switcher
0.7.3
true
{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
Java Quick Starter
1.0
false
jqs@sun.com
Modified Preferences
Name
Value
accessibility.blockautorefresh
true
accessibility.typeaheadfind.flashBar
0
browser.display.background_color
#000000
browser.display.foreground_color
#C0C0C0
browser.display.use_document_colors
false
browser.display.use_document_fonts
0
browser.display.use_system_colors
true
browser.history_expire_days.mirror
180
browser.history_expire_days_min
14
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
about:blank
browser.startup.homepage_override.buildID
20120215223356
browser.startup.homepage_override.mstone
rv:10.0.2
dom.disable_open_during_load
false
dom.disable_window_open_feature.directories
true
dom.disable_window_open_feature.menubar
true
dom.disable_window_open_feature.scrollbars
true
dom.disable_window_open_feature.toolbar
true
dom.event.contextmenu.enabled
false
dom.max_chrome_script_run_time
40
dom.max_script_run_time
40
dom.popup_allowed_events
change click dblclick reset submit
dom.storage.enabled
false
extensions.lastAppVersion
10.0.2
font.default.x-western
sans-serif
font.minimum-size.x-western
12
font.size.fixed.x-western
12
font.size.variable.x-western
14
general.autoScroll
false
gfx.blacklist.direct2d
2
gfx.blacklist.layers.direct3d10
2
gfx.blacklist.layers.direct3d10-1
2
gfx.blacklist.layers.direct3d9
5
gfx.blacklist.layers.opengl
4
gfx.blacklist.webgl.opengl
4
network.cookie.blockFutureCookies
true
network.cookie.cookieBehavior
2
network.cookie.lifetimePolicy
2
network.cookie.prefsMigrated
true
network.http.max-connections
32
network.http.max-connections-per-server
16
network.http.max-persistent-connections-per-server
4
network.http.pipelining
true
network.http.pipelining.maxrequests
10
network.http.proxy.pipelining
true
places.database.lastMaintenance
1357350261
places.history.expiration.transient_current_max_pages
13370
places.last_vacuum
1326407457
plugins.hide_infobar_for_outdated_plugin
true
print.always_cache_old_pres
true
privacy.clearOnShutdown.history
false
privacy.clearOnShutdown.offlineApps
true
privacy.clearOnShutdown.passwords
true
privacy.cpd.history
false
privacy.donottrackheader.enabled
true
privacy.item.cookies
true
privacy.item.history
false
privacy.item.offlineApps
true
privacy.item.passwords
true
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.promptOnSanitize
false
privacy.sanitize.sanitizeOnShutdown
true
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.enable_java
false
security.enable_ssl3
false
security.warn_entering_secure.show_once
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) 82810 Graphics Controller
Vendor ID
8086
Device ID
7121
Adapter RAM
Unknown
Adapter Drivers
i81xdnt5
Driver Version
6.13.1.3196
Driver Date
7-23-2002
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
Unknown
WebGL Renderer
false
GPU Accelerated Windows
0/2. Blocked for your operating system version.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Chosen Solution

Do you have the network.cookie.blockFutureCookies set to true on the about:config page?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

network.cookie.blockFutureCookies;true

I was not aware of this setting and not sure why it was set to true. Based on the description of the setting, I believe this is probably what is causing the issue. I had been manually deleting cookies from specific sites when I have trouble signing in, and those sites seem to be the ones for which cookies were being blocked. I will try setting that property to false and see if that resolves the problem. If not, I will try safe mode and troubleshooting extensions. Thank you very much for your assistance cor-el.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

You're welcome

Yes, if this pref is set to true then you automatically block cookies from a domain by deleting cookies from it.
So resetting the pref to false should fix this.

If you do not keep the change then check for extension or a possible user.js file that sets this pref.

Question owner

I tried toggle on the property and it set to false, and tested the result, and it seemed to solve the problem. The odd thing is that it still said "user set" (on both true and false) so I tried reset then it changed from boolean to string ""; weird. Whatever it is as long as it's not set to boolean true (or even if it's deleted) it appears to have solved the problem I was having. Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Helpful Reply

Yes, this pref is a hidden pref and only appears on the about:config page if you have created it yourself.
A reset of such a pref makes it show as an empty String value and a restart of Firefox will remove such a pref, so what you see is perfectly normal.