X
Tap here to go to the mobile version of the site.

Support Forum

Check my spelling as I type

Posted

I am not able to get Firefox 17 to retain the option to check my spelling as I type in the context menu but the option is retained under options advanced browsing. If I want to verify the spelling of a word and use the spell checker I have to right click on the word in question then select check my spelling as I type in the context menu by placing a check mark by the option.

I am not able to get Firefox 17 to retain the option to check my spelling as I type in the context menu but the option is retained under options advanced browsing. If I want to verify the spelling of a word and use the spell checker I have to right click on the word in question then select check my spelling as I type in the context menu by placing a check mark by the option.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.872
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Steps taken in an effort to resolve the problem.
1) Toggled the setting and restarted Firefox.
2) Pursued About:Config information but found none.
3) Pursued information regarding other files that store configuration such as js files but found none.
I upgrade from Firefox 3.6 where I used Spell Bound to 14 then each time you released a new version of 14 I upgraded and followed that process through versions 15, 16 and 17 which have all had the same problem. I assume the problem was created when you put the speller checker on back there some where and has never be addressed and corrected.

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1245 solutions 8211 answers

Helpful Reply

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: ''This will cause you to lose any Extensions, Open websites, and some Preferences.'' To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us!
cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers

Helpful Reply

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Do you have a dictionary installed and selected? You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected. *Open the "Add Dictionaries" link to install a dictionary if you do not have one. *Make sure that [X] "Check Spelling" in the right-click context menu is check-marked. You can enable or disable spell checking globally: *Tools > Options > Advanced : General: Browsing: "Check my spelling as I type" You can look here for dictionaries: *https://addons.mozilla.org/firefox/language-tools/