X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Spell Check is not working, still......

Posted

Another long time user that has been with you for years has had enough, over to Opera where I can write an email without looking like an unprofessional dummy that can't even use spell checker.

Linux mint 14, fully updated, two different pc's both same problem with spellchecker, this problem has been going on for a long time now. Do you really expect people to use a browser without a spellcheck? This has been a 'bug' for how long now? People just go elsewhere, why wouldn't you, try running a business and sending people sketchy looking emails.

I fix PC's for a living, I used to put everybody onto Thunderbird and Firefox, do you think I still do that? Obviously like the people I know who do the same thing for a living, I put them onto Chrome so they don't ring me complaining that it doesn't work properly.

You guys are loosing market share for a reason, we need a functional non bloated browser that doesn't freeze and crash all the time, forget the fancy add-ons and themes, make the basics work because from the techiest person to the most useless pleb luddite, we all need the basics to work or the browser is a useless piece of crap.

This site is proof of how you are alienating people too, I go to register and it tells me I don't need to register for a new question, I click on that and half way through it asks me to register, then when registering it took about 6 tries for your javascript to accept it: "username too short", "password is short", "username exists". Tell us before ffs! I nearly gave up and shut the window. Anybody unfamiliar with pc's would have given up after a try or two and gone back to IE.

Please, please, get your stuff together, I love Mozilla and I love Firefox, it's named after my favourite baddies in the original Donkey Kong, ffs, I love you guys, get back to basics and make a functional browser that people prefer to IE, you are killing it, get back to basics and make it FUNCTIONAL

Modified by Noah_SUMO

Additional System Details

Installed Plug-ins

  • This plugin provides integration with Cinnamon for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The IcedTea-Web Plugin executes Java applets.
  • The Totem 3.4.3 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Fix the bug, just fix it already, and me and countless others return.
MOZILLA MAKE SPELLCHECK WORK OR GTFO OF THE BROWSER GAME FFS
Sorry for my rant but goddamn, really, spellchecker still not working and I've been stupid enough to put up with it for this long? I'm damn upset, I thought I would always use firefox, my brand loyalty was the only thing keeping me hanging on, I hate Opera but the spellcheck works, so for me it is way more functional than Thunderbird or Firefox.
Please don't let it die.

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

You can enable or disable spell checking globally:

Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

JamesRM 0 solutions 1 answers

Helpful Reply

I had this problem too, spell check stopped working, I presume after an update. The solution is to add a dictionary, which you can by going to

Firefox language Tools

Though why this link is not on the same option tab as the spell check checkbox is beyond me. It appears that if your locale is US, Firefox is supposed to load the US dictionary, otherwise none. Pretty dumb, eh?

Blaine91555 0 solutions 2 answers

It will not stay active on Windows 7 64 bit. We have the global settings right.

Oddly on my old laptop running Vista, it works fine. Re-installation does nothing either.

Having to remember to right click and turn it on every time is a pain in the.......

Blaine91555 0 solutions 2 answers

Should mention that adding a dictionary is not relevent. I need to know why it works globaly on one computer, but not another.

Lodestar 0 solutions 3 answers

Not sure if I am reporting the same thing as the poster above. Early last year I had windows 7 reinstalled, and when I put what was then the latest version of firefox on, I noted I had no spellchecker, even though it was clearly selected with a check box.

I reinstalled windows 7 again after some hardware maintainece, and along with an odd windos 7 issue with the screen saver (having to get that dealt with elsewhere), the same spell check issue ocurred. It seems to basically be acting as though it is not switched on. I uninstalled and put on english GB version which is correct for me, and still nothing.

Any ideas?

EDIT: Have a version of Firefox on my fathers Laptop put on after the first reinstall early this year, and spellcheck works fine there.

Modified by Lodestar

cor-el
  • Top 10 Contributor
  • Moderator
10757 solutions 96831 answers

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.

At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Lodestar 0 solutions 3 answers

Can't see any Lamguages sub menu. Least not by using the method you described. All I get when right clicking on a text area are :

UNDO, cut, copy cut and paste, select all, Add dictionaries and inspect element.

cor-el
  • Top 10 Contributor
  • Moderator
10757 solutions 96831 answers

That means that most likely you do not have a dictionary installed and you will have to install one to make spell checking work.

Note that not all locales come with a dictionary.

You can look here for dictionaries:

See also:

Lodestar 0 solutions 3 answers

Ok thanks, give this a go. But, before I do, please clarify, DICTIONARY NOT LANGUAGE PACK. That correct? And while we at it, what is the difference?

Thanks for the help so far.

cor-el
  • Top 10 Contributor
  • Moderator
10757 solutions 96831 answers

Yes, you need a dictionary.

A dictionary is for the spell checker.
A language pack contains localized strings to be used in the user interface (menu bar and other windows)

Modified by cor-el

canetti 0 solutions 3 answers

Running Firefox 21 on Windows 7. Adding a dictionary is not helping. While it seems to add, when I fight click on a misspelled word I get "no suggestion".