X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps "Not Responding" and freezing my computer

Posted

As of late, my Firefox browser has been freezing my entire computer. It keeps saying that it is "not responding", my mouse turns into that blue circular loading screen, I can't exit anything, I can't even open task manager, I have to take the battery out just for my computer to turn off.

I scanned everything with Norton; didn't detect anything. I even did the Norton Power Eraser, still nothing. I set Firefox to run the program as an administrator and I thought it was fixed but it wasn't.

I even update my plug-ins and for some reason, your website keeps telling me I need to update the same ones, so I can't even rely on that.

I noticed that it does happen when I'm on a Youtube page. Like when I've paused a video.

It opens fast, it browses fast, it goes to certain websites fast. It's this annoyance that has really bothered me and has considered me switching to Google Chrome.

If you don't want me to, then tell me how to fix this issue.

Chosen solution

Try to disable hardware acceleration in Firefox.


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps in case your security software or custom system drivers are causing issues.

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 4.1.10329.0
  • NPWLPG
  • Yahoo Application State Plugin version 1.0.0.7
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Chosen Solution

Try to disable hardware acceleration in Firefox.


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps in case your security software or custom system drivers are causing issues.

Question owner

It didn't work.

All it did was make me move my mouse to minimize programs but it wouldn't let me use ctrl +alt +del to open task manager.

Now everytime I turn on my computer; I read a message saying my battery is low and needs to be replaced for optimal performance but I keep my computer plugged in all the time.

Question owner

I think I figured out what the problem was. Norton was running in the background which started to freeze up my computer. The reason being that my computer only froze when I wasn't using it; when it was idle.

I apologize for blaming your browser; it was on while my computer froze so I assumed it was that. Hey, again, I apologize and will stick with Firefox since it had nothing to do with it.

I am considering getting a different anti-virus program though.

Thanks for your help.

cybervigilante 0 solutions 12 answers

Same problem here. FF freezes my whole computer. No "solution" (shot in the dark") works. I may be forced to migrate to Chrome. (NEVER IE ;'P)

getMobilised 0 solutions 2 answers

Helpful Reply

I am having the same problem... it seems isolated to the version I was running at the time which was V21.0.

Less than a week ago it just hung/froze my system completely for no reason..no keyboard no mouse no luck...

I am running Windows 7 Enterprise x64 Bit and runs well with no other issues.. here's what I tried...

Uninstalled Firefox completely including all personal data, caches, etc, then I downloaded a fresh copy from mozilla.org (V21.0) and installed it.

Now I have the same issue!

Chrome runs perfectly as does Internet Explorer, so does any one have any ideas as to what changed in this version that would cause such a condition to occur?

getMobilised 0 solutions 2 answers

BTW, I hadn't changed anything or added anything to my system recently.

cybervigilante 0 solutions 12 answers

I haven't had this happen the last week. The only change I made was putting offending background sites in the hosts file. Webmasters are having more and more sites load in the background - ad sites, analytics sites, resource sites, etc. It goes on and on in the lower left corner. I noticed some sites seemed to take forever to load, and that stalled Firefox. So I put those sites in the hosts file, where they are blocked from even being accessed.