Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error message says I must be using Firefox to install add-on - I am using FIrefox!

  • 2 replies
  • 4 have this problem
  • 127 views
  • Last reply by cor-el

more options

I'm trying to install the add-on <always ".com" - Google.com (in English)> and the following error message:

"Sorry, you need a Mozilla based browser (such as Firefox) to install a search plugin."

Which is a little odd since I've been using Mozilla exclusively for more years than I can remember. Can someone please explain why Mozilla can't detect that I'm using Firefox?

All Replies (2)

more options

The Add-on is not available for the latest version of Firefox (or) Removed by the user.

more options

Make sure that you do not block JavaScript.
Try install that search engine in Safe mode if it doesn't work in normal mode.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.