X
Tap here to go to the mobile version of the site.

Support Forum

Scrolling with trackpad in bookmarks doesn't work

Posted

As per the title.

Scrolling within a list of bookmarks doesn't work. Scrolling in a drop down menu doesn't work either. Has anyone experienced the same and found a solution?

Scrolling works fine on pages in Firefox but not within bookmarks.

Scrolling through bookmarks in IE9 works fine.

I have the Flash/Youtube issue too but I'm guessing its not related.

Thanks.

As per the title. Scrolling within a list of bookmarks doesn't work. Scrolling in a drop down menu doesn't work either. Has anyone experienced the same and found a solution? Scrolling works fine on pages in Firefox but not within bookmarks. Scrolling through bookmarks in IE9 works fine. I have the Flash/Youtube issue too but I'm guessing its not related. Thanks.

Modified by sgotts500

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
avast! WebRep
7.0.1474
false
wrc@avast.com
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
extensions.lastAppVersion
17.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1356020949
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics Family
Vendor ID
0x8086
Device ID
0x0126
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Driver Version
8.15.10.2291
Driver Date
1-27-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

the-edmeister
  • Top 10 Contributor
  • Moderator
3883 solutions 29363 answers

"Scrolling within a list of bookmarks doesn't work."

Three different displays of bookmarks list, which one?

1. Menu bar drop-down
2. Library window
3. Bookmarks sidebar

''''' "Scrolling within a list of bookmarks doesn't work." ''''' Three different displays of bookmarks list, which one? 1. Menu bar drop-down <br /> 2. Library window <br /> 3. Bookmarks sidebar

Question owner

The Menu drop down bar and the Bookmarks sidebar.

The Menu drop down bar and the Bookmarks sidebar.

Modified by sgotts500

cor-el
  • Top 10 Contributor
  • Moderator
12019 solutions 111693 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Thanks for the reply.

Tried safe mode. Problem still persists. Disabled all plug ins. No change.

Anything else I should try?

Thanks for the reply. Tried safe mode. Problem still persists. Disabled all plug ins. No change. Anything else I should try?

Question owner

Update. The problem occurs in any drop menu.

Any help much appreciated. I'm sure its hardware related as I'm using windows 7 64 bit on a HP 8460. With windows XP I never had a problem. It's getting to the point where I prefer not to use FF which is a shame.

Update. The problem occurs in any drop menu. Any help much appreciated. I'm sure its hardware related as I'm using windows 7 64 bit on a HP 8460. With windows XP I never had a problem. It's getting to the point where I prefer not to use FF which is a shame.
madaload 0 solutions 2 answers

Helpful Reply

Same problem here on two different HP laptops. I really hope Mozilla can fix this problem, maybe in collaboration with HP. It must have something to do with HP's hardware customization. HP do their stuff their way and customers suffer. I've had no such problem on any other laptop and they were all using Synaptics touchpads.

I have lots of Bookmarks and it is really annoying to wait for them to scroll automatically with the cursor placed over the little arrow bar at the bottom of Bookmarks dropdown list. If you use an external mouse, you can scroll through Bookmarks with it just fine, so the problem is with the touchpad.

Same problem here on two different HP laptops. I really hope Mozilla can fix this problem, maybe in collaboration with HP. It must have something to do with HP's hardware customization. HP do their stuff their way and customers suffer. I've had no such problem on any other laptop and they were all using Synaptics touchpads. I have lots of Bookmarks and it is really annoying to wait for them to scroll automatically with the cursor placed over the little arrow bar at the bottom of Bookmarks dropdown list. If you use an external mouse, you can scroll through Bookmarks with it just fine, so the problem is with the touchpad.

Modified by madaload

madaload 0 solutions 2 answers

Helpful Reply

I have now found a proper solution. Turns out Firefox and Synaptics don't like each other too much. The scrolling problem has been going on for years in one way or another and neither side seems to care enough to provide a permanent solution.

I have found a registry fix in one of the older debates about a similar problem. My addition to the fix is that you must make sure that Vertical Scrolling is enabled in Synaptics preferences. It may seem like it is, but the registry fix won't work unless scrolling is really enabled. Once that is confirmed, all you have to do is to add this registry entry into [HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh]: "UseScrollCursor"=dword:00000000

If you don't know how to do it manually, just create a .txt document on your Desktop, open it and copy/paste this into it:


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000


Save it as a .reg file, then double-click it and confirm the action when promted. Restart Firefox or even Windows and there, Bookmarks scrolling now works!

I would recommend you to use the drivers provided by your laptop manufacturer, even if they are older than what Synaptics have on their website.

I have now found a proper solution. Turns out Firefox and Synaptics don't like each other too much. The scrolling problem has been going on for years in one way or another and neither side seems to care enough to provide a permanent solution. I have found a registry fix in one of the older debates about a similar problem. My addition to the fix is that you must make sure that Vertical Scrolling is enabled in Synaptics preferences. It may seem like it is, but the registry fix won't work unless scrolling is really enabled. Once that is confirmed, all you have to do is to add this registry entry into '''[HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh]''': "UseScrollCursor"=dword:00000000 If you don't know how to do it manually, just create a .txt document on your Desktop, open it and copy/paste this into it: Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000 Save it as a .reg file, then double-click it and confirm the action when promted. Restart Firefox or even Windows and there, Bookmarks scrolling now works! I would recommend you to use the drivers provided by your laptop manufacturer, even if they are older than what Synaptics have on their website.

Modified by madaload

Question owner

Madaloas - Thanks for sharing. I will try your solution and report back.

Madaloas - Thanks for sharing. I will try your solution and report back.