Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opening multiple tabs when I click on an email address.

  • 16 replies
  • 4 have this problem
  • 2755 views
  • Last reply by cor-el

more options

This is the second time I'm filling in all of this information, I hope it works this time.

A while back I changed mailto to Firefox in Options>Applications>mailto After that, when I would click on an email address, Firefox would open new tabs VERY quickly and would not stop until I used Task Manager to close Firefox. I then went back and changed mailto back to Always Ask. But the same thing still happens when I click an email address, Firefox opens tabs very rapidly until I close it with task manager. I then checked the settings in about:config "network.protocol-handler.external.mailto" and it is set to default, boolean, true I don't want a default email program to be set, I want it to always ask. Please help with this. Thank you.

Chosen solution

Did you delete the delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
Read this answer in context 👍 1

All Replies (16)

more options

Please update to Firefox 17.0.1, then test again.

more options

You get that problem if you select the Firefox program to handle a file if you get an "open with" dialog.

more options

I updated to 17.0.1 and now the problem is worse than before!! When I click on an email address, and Firefox begins opening tabs VERY rapidly, I have to click end task in Task Manager, same as it before the upgrade. Before I upgraded, that was the end of it. Now, immediately after closing Firefox, it reopens by itself and continues opening tabs as fast as it can. Over and over again. Nothing I can do will stop Firefox from opening again, and opening tabs quickly. I had to unplug my computer to get it to stop.

more options
more options

Chosen Solution

Did you delete the delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
more options

Cor-el, your suggestion to delete the mimetypes.rdf file solved my problem! Thank you very much!! I don't know if these questions are ever "closed" or labeled as "resolved" but if so, you may mark this one resolved! Thank you so much!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

more options

You're welcome

more options

I have the same problem on a Mac OS 10.8.3 and Firefox 21.0 (the latest version).

I followed your directions but it doesn't fix the problem. Is there a fix for the Mac?

Thanks!


MimeTypes.rdf does not exist on my computer

browser.download.pluginOverrideTypes does not exist on my computer

plugin.disable_full_page_plugin_for_types does not exist on my computer

more options

Resetting Firefox does not work either.

more options

In Mac OS X v10.7 and later, the $HOME/Library folder is a hidden folder.

Open Finder and use one of these:

  • Go > Go To Folder (Shift-Command-G) and in the dialog type: ~/Library
  • Open the "Go" menu and hold down the Option key to make the Library appear

Which files are in the Firefox profile folder?
The mimeTypes.rdf files should be one of them.

Did you use the button on the Help > Troubleshooting Information page?

more options

I know about the hidden folder. I deleted 4 mimeTypes.rdf files on this 4th try to fix.

>Did you use the button on the Help > Troubleshooting Information page?

Yes and if you mean resetting Firefox I mentioned that I did so in earlier attempts and have done so again.

The problem still exists. It seems like a major bug that needs fixing.

Thanks for your help.

more options

What is the Mailto setting in Tools > Options > Applications?

You can also check the network.protocol-handler.external.mailto prefs on the about:config page.

If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value.

more options

>What is the Mailto setting in Tools > Options > Applications?

This menu path doesn't exist on a Mac. Are you using a Mac?

more options

Sorry about the confusion.

On Mac you can find them in Firefox > Preferences > Applications

more options

YooHooo!! That finally fixed it!! It was set to Firefox (default). I changed it to Gmail, which is what I use, and no more millions of tabs!!

Thank You for being so persistent and helpful!

more options

You're welcome.