X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Watch video on other pages then Youtube

Posted

Hi! I can not watch videos on other pages than youtube. Even if it is a youtube movie link or different type of video. The area where the video is supposed to be is just a blank area and when I press it the video starts and I can hear the audio, but not see the video. I have tried all the fixes I could find, different plug-ins, upgraded my plug-ins, downgraded the flash player from 11.2 or 3 to 10.3 and so on. I have Firefox 17 and have downgraded my flash player to 10.3. I also have RealPlayer installed (but not as a plugin?). I can see the videos no problem in Internet Explorer but they are blank in Firefox and I only hear audio. On pages with youtube videos can watch them if I copy the URL and load to youtube video in a different tab, but this is to cumbersome.

Please help

Additional System Details

Installed Plug-ins

  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) G2 LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Shockwave Flash 10.3 r183
  • AVG sitesafety plugin 12.0
  • The QuickTime Plugin 7.7.3
  • Facebook Video Calling Plugin 1.2.0.287
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.638
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • SiteAdvisor
  • 5.1.10411.0
  • VLC media player Web Plugin 2.0.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • DivX Web Player version 1.5.0.52

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Jan. 9 solutions 82 answers

Helpful Reply

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.


Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can also check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin

Question owner

It was the hardware acceleration. Thanks you random citizen! You are awesome

KAPAMAN 0 solutions 3 answers

Helpful Reply

DEAR SALABLE, I TRIED EVERYTHING EVERYONE TOLD ME TO DO. NOTHING WORKED. CAME UP WITH THIS ON MY OWN. IT WORK FOR ME. NO MORE PROBLEM. INSTALL ADOBE ACTIVE X 11.6.602.168 AND ADOBE FLASH PLAYER 11 PLUGIN 11.602.168. THEN CHECK YOUR PLUGINS. UPDATE OR DOWNLOAD JAVA DEPLOYMENT TOOL KIT 7.0.150.3 10.15.2.3 NP RUNTIME SCRIPT. THEN UPDATE OR INSTALL JAVA (TM) PLATFORM SE7U15 10.15.23 NEXT GENERATION JAVA PLUGIN 10.15.2 FOR MOZILLA BROWSER. I CAN WATCH YOUTUBE OR ANY OTHER VIDEO SOURCE. AOL, YAHOO, GOOGLE, ALL IS GOOD. !!! AND GOOD LUCK TO YOU.