X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 17: Google Search Autocomplete Disabled

Posted

Warning: If you upgrade to Firefox 17 and use Google's old search -

https://www.google.com/webhp?complete=0&hl=en

the autocomplete (drop-down box of you personal search terms) is disabled and per Google is not a Google issue

Again if you use https://www.google.com/webhp?complete=0&hl=en

your typed search history contained in the drop-down box is eliminated with Firefox 17, and once again Google has verified that it is not a Google issue.

Hopefully Firefox fixes this issue because tens of millions of people who use Google's old Search Engine -

https://www.google.com/webhp?complete=0&hl=en

use it because it retains your typed search history while eliminating google's suggestions, making searches fast and precise and effective and efficient without google's clutter of suggestions, yet Firefox 17 disables it altogether

Chosen solution

Autocomplete On has been updated, uninstall and remove the old Autocomplete On and reinstall the new version, version 10:

http://userscripts.org/scripts/show/7347

Thanks to Matthew Schultz.

http://userscripts.org/topics/21362

Version 10 changes:

-Added version metatag so any future versions released should allow this script to be auto updated -Added Firefox 17 support: Since Firefox 17 no longer interprets // (double slash) comments and returns a syntax error when using the location hack, converted all comments to multiline /* */ (slash star) comments.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Contacted Google and technician verified issue is not a Google issue

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello SirSimeon2003, this issue is caused by google since the source code of the search form explicitly specifies that the input shouldn't be autocompleted with your prior typed search history (autocomplete="off").

Question owner

Nope, as I stated twice above, Google verified it was not a Google issue

And the issue was resolved when I reverted back to Firefox 16.0.1

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

well google can say otherwise, but it's obvious from the source-code that autocomplete is switched off for this form (see screenshot attached). it didn't work for me when i downgraded to firefox 16 or firefox 10 either. by using a bookmarklet that ignores the autocomplete=off element temporarily it is possible to circumvent this restriction but this is not a very practical solution...

Mike109 0 solutions 18 answers

Using the above URL for has been the work around to enable autocomplete for quite some time.

I restored back to FF14 and autocomplete still works just like it has for many other versions of FF. (I never had FF15 or FF16).

So why has FF17 made it stop working?

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

were these autocomplete-entries coming from firefox' inbuilt form-history or from google.com that keeps track of your search history when you're logged in?

Modified by philipp

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

If you're talking about Google search suggestions, I see the same thing in Internet Explorer Internet Explorer 9 and Firefox 10.0.11 ESR as in Firefox 17 when searching from https://www.google.com/webhp?complete=0&hl=en (no drop-down list of search suggestions).

Does it help if you search from www.google.com instead ? (I get google search suggestions from there.)

Ref: http://www.ehow.com/how_8549105_rid-dropdown-suggestion-list-google.html
Quote: You can also disable Google's search suggestions by using the URL "http://www.google.com/webhp?complete=0" to access the search engine. Set this URL as your browser's homepage so you do not have to type it manually each time you perform a Web search.

Some other references, in case it helps:

Modified by AliceWyman

Mike109 0 solutions 18 answers

Helpful Reply

The data is kept in a Firefox profile folder. IIRC if is called places.sqlite. Firefox should be able to have access to its own file. Again, this has worked with previous versions of Firefox.

This may help explain a few things. Take a look at the top entry here. Obviously I am not the only one having this problem. I’m presuming as more people update to FF17 there will be more complaints about this. https://support.mozilla.org/en-US/search?q=autocomplete&esab=a&page=1

Here’s a couple earlier links explaining things from some time ago when the fix was found

http://forums.mozillazine.org/viewtopic.php?f=38&t=2451263

http://community.norton.com/t5/Norton-Internet-Security-Norton/Firefox-Autocomplete-stopped-working/td-p/688921

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

the links you've posted date back to march this year - there was no ff17 around back then. the link to the mozillazine forum bolsters what i've written above: the problem occurred with other browsers as well and the workaround is to use a userscript which circumvents the autocomplete=off parameter that google has put into the source code of the page. so it is intended behaviour (by google) that no suggestions from any browsers' inbuilt form history are displayed when typing in the search box.

the only way i can think of why it may have worked for you before is that some sort of addon has modified the behaviour, which has now stopped working with firefox 17 for whatever reason. could you list all your installed entries in firefox > addons > extensions?

Mike109 0 solutions 18 answers

Helpful Reply

I know that Google changed things & it affected other browsers.

I realize there was no FF17 back in March. That is my point. Every version since then has worked with that long Google URL, except FF17. https://www.google.com/webhp?complete=0&hl=en

I'm not saying FF caused the problem, but there was a fix that enabled FF to work around it. Obviously something has changed with FF17. And it appears others are not happy about it either & just might change browsers because FF does not give them a feature they liked.

Question owner

To re-iterate and add to what Mike1009 said:

The old Google Search page retains the words you yourself type into the search box while disabling Google suggestions.

( I stated the above at least twice in the original message and I'm not sure what part of the concept is so hard for "Top Contributors" to grasp....)

Since late 2011 to the present Firefox updates have disabled the ability of the old Google Search page to retain the words you yourself type while disabling Google suggestions.

However, Since late 2011 until Firefox 17, the userscript "AutoComplete On" fixed the problem, forcing the old Google Search to do what it was designed to do - retain words you yourself type in the search box while disabling Google Suggestions.

Firefox 17 overrides the aforementioned userscript which forcibly disables the core functionality of the old Google search.

Google techs and reps have repeatedly stated Google in no way altered or disabled their old Google Search. This is a fact because in older versions of Firefox pre-dating Firefox 12, the old Google Search functions as it was intended to function without the aforementioned userscript, and the old Google search functions perfectly in Firefox versions 13, 14, 15, 16 with the userscript.

I left a message on the page of the userscript -

http://userscripts.org/scripts/show/7347

n hopes the designer can tweak the script, but based on the language of the script, the script is written to work on all versions of all browsers, so I doubt the designer can "fix" the script.

It's up to Firefox to undo it's dismantlement of the core functionality of the old Google Search, something I never asked or expected Firefox to do. My original message was a warning to people who use the old Google Search, especially people who make that their home page.

I'm sticking with Firefox 16.0.1 and weakly hope but don't expect post-Firefox 17 updates to restore the core functionality of the old Google Search.

Modified by SirSimeon2003

Mike109 0 solutions 18 answers

SirSimeon2003,

I think I forgot to mention that I am using the “Autocomplete On” script in Greasemonkey. http://userscripts.org/scripts/show/7347

I just looked at Greasemonkey & it says “No installed scripts run on this page”. When I select “Manage User Scripts” it does indicate I have “Autocomplete On”. I just wanted to confirm that it is still there.

Modified by Mike109

Mike109 0 solutions 18 answers

I just got rid of FF 17 and installed FF 16.0.2 and the autocomplete does work just like it used to.

MrWolf 0 solutions 5 answers

Hi all! Take a look at this discussion: http://forums.mozillazine.org/viewtopic.php?f=38&t=2451263 and try this script: https://userscripts.org/scripts/show/129837 Actually, I'm not using Firefox 17, but Firefox 16, since it's not compatible with some addons I need.

Mike109 0 solutions 18 answers

I tried a couple times the script that you just suggested but have problems with it. My auto complete list does appear, however after selecting a link & hitting “Enter” or clicking on “Google Search” the PC just does not respond. Nothing happens until I hit “Enter” several times.

That is while still using FF 16.0.2. I have not re-installed FF17 to see if that script works. I’m just presuming if there is a problem with FF16 then there will be a problem with FF17.

In the meantime FF 16.0.2 works with the previous “Autocomplete On” script. I guess at some point I’ll have to try something with FF17.

MrWolf 0 solutions 5 answers

Disable Google Autocomplete has worked well with me till Firefox 16. I haven't tried it yet with Firefox 17. The fact that, if you click on "search with Google", nothing happens is an issue, I posted something about it on the script page: https://userscripts.org/topics/112960 While hitting enter works.

Modified by MrWolf

Mike109 0 solutions 18 answers

I’ve been using the “Autocomplete On” that you suggested some time ago & it has worked until FF17. The “Disable Google Autocomplete” is new to me so I never tried it before. With FF16.0.2 I have to hit “Enter” several times in order to proceed.

I tried several combination of “Autocomplete On” and “Disable Google Autocomplete” using google.com and http://www.google.com//webhp?complete=0&hl=en.

“Autocomplete On” with the regular google.com is kind of interesting. It overlays my selections on top of Google’s suggestions. Depending how long my list is, it may or may not cover up part of Google’s list. So if my list is short I get both lists which could be helpful. I’ll have to play with that option for a while & see how I like it.

At some point I’ll have to upgrade to a newer version of FF for security reasons & hopefully one of the “Autocomplete On” scripts will then work. I wish I knew more about how these scripts interacted with FF. They’re obviously able to pull up the history from the profiles folder up to FF16. Some programmer might be able to figure out how to modify the script to work with FF17 but I just don’t think there is much of a demand for the way the few of us are using auto complete.

MrWolf 0 solutions 5 answers

Just tried "Disable Google Autocomplete" with Firefox 17 and, so far, it works as earlier, no issues found, my previous searches in Google are still there. Maybe you can try with a clean installation of Firefox 17?

Question owner

Temporary Fix:

Create a new bookmark (see below)

Click on it every time you want to search

Bookmark changes "Autocomplete=Off" to "Autocomplete=On"

Bookmark Name: Autocomplete On

Bookmark Description:

   javascript:(function(){var%20ca,cea,cs,df,dfe,i,j,x,y;function%20n(i,what){return%20i+%22%20%22+what+((i==1)?%22%22:%22s%22)}ca=cea=cs=0;df=document.forms;for(i=0;i<df.length;++i){x=df[i];dfe=x.elements;if(x.onsubmit){x.onsubmit=%22%22;++cs;}if(x.attributes[%22autocomplete%22]){x.attributes[%22autocomplete%22].value=%22on%22;++ca;}for(j=0;j<dfe.length;++j){y=dfe[j];if(y.attributes[%22autocomplete%22]){y.attributes[%22autocomplete%22].value=%22on%22;++cea;}}}alert(%22removed%20autocomplete=off%20from%20%22+n(ca,%22form%22)+%22%20and%20from%20%22+n(cea,%22form%20element%22)+%22,%20and%20removed%20onsubmit%20from%20%22+n(cs,%22form%22)+%22.%20after%20you%20type%20your%20password%20and%20submit%20the%20form,%20the%20browser%20will%20offer%20to%20remember%20your%20password.%22)})(); <="" pre=""></df.length;++i){x=df[i];dfe=x.elements;if(x.onsubmit){x.onsubmit=%22%22;++cs;}if(x.attributes[%22autocomplete%22]){x.attributes[%22autocomplete%22].value=%22on%22;++ca;}for(j=0;j<dfe.length;++j){y=dfe[j];if(y.attributes[%22autocomplete%22]){y.attributes[%22autocomplete%22].value=%22on%22;++cea;}}}alert(%22removed%20autocomplete=off%20from%20%22+n(ca,%22form%22)+%22%20and%20from%20%22+n(cea,%22form%20element%22)+%22,%20and%20removed%20onsubmit%20from%20%22+n(cs,%22form%22)+%22.%20after%20you%20type%20your%20password%20and%20submit%20the%20form,%20the%20browser%20will%20offer%20to%20remember%20your%20password.%22)})();>
Mike109 0 solutions 18 answers

MrWolf -

I’ll give it a try & see how it works for me.

SirSimeon2003 -

You say to “Create a new bookmark (see below)”. However the Bookmark Description is a long script & I have no idea what to do with it. Is it just one very long url that I’m suppose to use?

Question owner

Scroll over to Bookmarks, right click, select "New Bookmark"

Name it "Autocomplete On", or what you will

Copy and Paste the above javascript code into "Description" box

Click new bookmark every time you need to search

It's a pain in the butt to click all the time

But it's the only current work-around

Modified by SirSimeon2003