X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 17: Google Search Autocomplete Disabled

Posted

Warning: If you upgrade to Firefox 17 and use Google's old search -

https://www.google.com/webhp?complete=0&hl=en

the autocomplete (drop-down box of you personal search terms) is disabled and per Google is not a Google issue

Again if you use https://www.google.com/webhp?complete=0&hl=en

your typed search history contained in the drop-down box is eliminated with Firefox 17, and once again Google has verified that it is not a Google issue.

Hopefully Firefox fixes this issue because tens of millions of people who use Google's old Search Engine -

https://www.google.com/webhp?complete=0&hl=en

use it because it retains your typed search history while eliminating google's suggestions, making searches fast and precise and effective and efficient without google's clutter of suggestions, yet Firefox 17 disables it altogether

Chosen solution

Autocomplete On has been updated, uninstall and remove the old Autocomplete On and reinstall the new version, version 10:

http://userscripts.org/scripts/show/7347

Thanks to Matthew Schultz.

http://userscripts.org/topics/21362

Version 10 changes:

-Added version metatag so any future versions released should allow this script to be auto updated -Added Firefox 17 support: Since Firefox 17 no longer interprets // (double slash) comments and returns a syntax error when using the location hack, converted all comments to multiline /* */ (slash star) comments.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Contacted Google and technician verified issue is not a Google issue

Mike109 0 solutions 18 answers

I do not get “New Bookmark” when right clicking on Bookmarks. However I did get it if I R/click on an existing bookmark. So I did that, & gave it a name & copy/pasted the script into the description box. However the “Add” function is grayed out. If I start entering something into the “Location” field then the “Add” function becomes available. Problem is I don’t know what to enter into the Location.

I'm still using FF16.0.2 if that make's a difference.

Question owner

Type something in the "Location" section as well ( I typed "java"), then the "Add" button should be enabled.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96738 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Make sure that you right-click in the right pane in the Bookmarks manager and that a valid location is selected like the Bookmarks Menu folder or one of its sub folders.
You can't add bookmarks under the root level.
You can also check the Organize menu via the first button after back and forward on the toolbar in the Library.

Question owner

Bumparoo

JMS 0 solutions 2 answers

It turns out to be a cookie issue (I know, everyone always says that). But its related to the same issue Firefox has with Facebook cookies, which sometimes makes the chat/message window stop working. It has something to do with how Google and Facebook handle the two different locations for cookies. You will notice that Google does not have the search bar issue when you are running in Private Browsing mode. That's because it handles the cookies differently in that mode.

Here's the fix:

Go to Tools>Options>Privacy and click on "Exceptions". In the text box at the top of the list type in "google.com" and click "Allow". Then type in "www.google.com" and click "Allow" again. Then "close" and "OK". Refresh the page and you should be good to go on Google.

It works well for me on Google's search page, as well as Facebook.

Question owner

Go to Tools>Options>Privacy and click on "Exceptions".

Firefox 17.0.1 does not have an "Exceptions" button under Tools-Options-Privacy....

MrWolf 0 solutions 5 answers

Look at "Cookies" option under "Privacy". However, allowing cookies doesn't turn autocomplete on. Autocomplete off ins inside the page code.

Modified by MrWolf

Chosen Solution

Autocomplete On has been updated, uninstall and remove the old Autocomplete On and reinstall the new version, version 10:

http://userscripts.org/scripts/show/7347

Thanks to Matthew Schultz.

http://userscripts.org/topics/21362

Version 10 changes:

-Added version metatag so any future versions released should allow this script to be auto updated -Added Firefox 17 support: Since Firefox 17 no longer interprets // (double slash) comments and returns a syntax error when using the location hack, converted all comments to multiline /* */ (slash star) comments.

MrWolf 0 solutions 5 answers

I've tried Autocomplete On, but I have problem: the new searches are not showed, only the old ones are. I opened a discussion on the script page: https://userscripts.org/topics/120309

Question owner

Just wanted to comment that I personally don't have that problem - the updated Autocomplete On with Firefox 17.0.1 is showing all of my old and new searches.

Can you post a list of all the Google-related scripts/extensions you have?

Are you using AdBlocker, and if so, what, if any, Google elements are you blocking or filtering or hiding?

There may be a conflict of interest between another Google-related script/extension/block/filter and the updated Autocomplete On.

Mike109 0 solutions 18 answers

I finally got around to updating to FF 17.0.1, and did need Autocomplete On vers 10. Now my old searches come up along with new ones.

Thank you everyone for all the help & information.

MrWolf - I hope you get your new searches to come up.

Question owner

LOL Firefox 18 is going to be released soon.....!