X
Tap here to go to the mobile version of the site.

Support Forum

Spell check working with some programs but not others

Posted

My spell check works on most sites and forms but not on others. The spell check box is already checked under options. How do I get the spell check to work on all forms?

My spell check works on most sites and forms but not on others. The spell check box is already checked under options. How do I get the spell check to work on all forms?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • 4.1.10329.0
  • npwangwang

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17414 solutions 157300 answers

It ids possible that websites disable the spell check. Google does this on the Google Translate website.

Did you check this in the right-click context menu?


You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

It ids possible that websites disable the spell check. Google does this on the Google Translate website. Did you check this in the right-click context menu? ---- You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. *Open the "Add Dictionaries" link to install a dictionary if you do not have one. *Make sure that [X] "Check Spelling" in the right-click context menu is check-marked. You can enable or disable spell checking globally: *Tools > Options > Advanced : General: Browsing: "Check my spelling as I type" You can look here for dictionaries: *https://addons.mozilla.org/firefox/language-tools/

Modified by cor-el

jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

For general information on spell check settings, see this thread: Check marks not showing in "options" spell check not working at all.

If it only affects particular forms, perhaps it's this: websites can disable spell checking on particular form controls where they feel that might improve the user experience (info: Controlling spell checking in HTML forms). This is done by adding spellcheck="false" to the HTML code for that control. There might be an add-on to bypass or ignore this.

For general information on spell check settings, see this thread: [https://support.mozilla.org/en-US/questions/929435 Check marks not showing in "options" spell check not working at all.] If it only affects particular forms, perhaps it's this: websites can disable spell checking on particular form controls where they feel that might improve the user experience (info: [https://developer.mozilla.org/en-US/docs/HTML/Controlling_spell_checking_in_HTML_forms Controlling spell checking in HTML forms]). This is done by adding spellcheck="false" to the HTML code for that control. There might be an add-on to bypass or ignore this.