X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The Add-On Manager keeps "Loading"

Posted

When I select "Add-Ons" or go to that tab, I get a Loading.... message continually. I have seen other reports on this problem that state I should click on extensions or plugins. I have tried this however the "loading...." persists. I have let it run for hours but it never loads. The reason I am trying to get the add-ons to load is because I have read that a certain add-on needs to be disabled in order to stop that annoying pop-up window that tells me about "Browser settings change". That is the real problem I am trying to get rid of. A previous post says to disable the recent add-on but I can't get the add-ons to load. Hope this is not too confusing.

Chosen solution

hello trader4300, this sounds like the files in your profile folder that store the information about your extensions might have become corrupted. please g to firefox > help > troubleshooting information > profile - show folder... then windows explorer should open up your profile folder. in there look for the files named extensions.ini, extensions.sqlite, extensions.sqlite-journal (and in some cases also extensions.txt, extensions.rdf). delete or rename those files and quit firefox, they will be regenerated the next time you launch firefox.

als see https://support.mozilla.org/en-US/kb/Unable%20to%20install%20add-ons#w_co...

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • np-mswmp
  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • 5.1.10411.0
  • Picasa plugin
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8897 answers

Chosen Solution

hello trader4300, this sounds like the files in your profile folder that store the information about your extensions might have become corrupted. please g to firefox > help > troubleshooting information > profile - show folder... then windows explorer should open up your profile folder. in there look for the files named extensions.ini, extensions.sqlite, extensions.sqlite-journal (and in some cases also extensions.txt, extensions.rdf). delete or rename those files and quit firefox, they will be regenerated the next time you launch firefox.

als see https://support.mozilla.org/en-US/kb/Unable%20to%20install%20add-ons#w_co...

Question owner

Yes, that fixed the Add-on not loading issue. Thank-you so much for that info.

Question owner

SOLVED