X
Tap here to go to the mobile version of the site.

Support Forum

When I go to open firefox it shows up on my tool bar but not on my screen where is it?

Posted

It feels like it's opening up in another screen in a dual screen situation...but I'm only only my laptop with the one screen.

It feels like it's opening up in another screen in a dual screen situation...but I'm only only my laptop with the one screen.

Chosen solution

It's possible that the window is "off screen".

If you make the Firefox tile active on the task bar and press this key combination, does it maximize into view?

Alt+Spacebar > x

(To clarify, that's Alt+Spacebar to open the window control menu, then the letter x to maximize the window.)

If that works, try this:

(1) Copy the following line of code to the clipboard:

newwin=window.open(window.location.href);newwin.moveTo(0,0);

(2) In the maximized window, press Ctrl+Shift+k to open the web console.

(3) Press Ctrl+v to paste the line of code next to the caret (>) then press Enter to run it. A new copy of that page should open in a window positioned at the top left of the screen.

(4) Switch back to the maximized window and close it first, before doing anything in the new window.

If you can't maximize Firefox, you can rename or delete the settings file that stores the last window position.

(1) Open your currently active Firefox settings folder (AKA Firefox profile folder).

From the Start menu, paste this into the search box and press Enter:

%APPDATA%\Mozilla\Firefox\Profiles

You may only have one folder, but if you have multiple folders, look for the most recent. Click into your profile folder.

(2) Switch back to Firefox and Exit completely.

(3) Wait a few moments for Firefox to finish updating files in your profile folder, then rename localstore.rdf to something else, like localstore-bad.rdf or localstore.old. Alternately, you can delete the file.

(4) You're done with your profile folder and you can restart Firefox now.

Any luck?

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

recently

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Picasa plugin
  • iTunes Detector Plug-in
  • Nitro PDF Plug-in for Firefox and Chrome
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
6617 solutions 54105 answers

Chosen Solution

It's possible that the window is "off screen".

If you make the Firefox tile active on the task bar and press this key combination, does it maximize into view?

Alt+Spacebar > x

(To clarify, that's Alt+Spacebar to open the window control menu, then the letter x to maximize the window.)

If that works, try this:

(1) Copy the following line of code to the clipboard:

newwin=window.open(window.location.href);newwin.moveTo(0,0);

(2) In the maximized window, press Ctrl+Shift+k to open the web console.

(3) Press Ctrl+v to paste the line of code next to the caret (>) then press Enter to run it. A new copy of that page should open in a window positioned at the top left of the screen.

(4) Switch back to the maximized window and close it first, before doing anything in the new window.

If you can't maximize Firefox, you can rename or delete the settings file that stores the last window position.

(1) Open your currently active Firefox settings folder (AKA Firefox profile folder).

From the Start menu, paste this into the search box and press Enter:

%APPDATA%\Mozilla\Firefox\Profiles

You may only have one folder, but if you have multiple folders, look for the most recent. Click into your profile folder.

(2) Switch back to Firefox and Exit completely.

(3) Wait a few moments for Firefox to finish updating files in your profile folder, then rename localstore.rdf to something else, like localstore-bad.rdf or localstore.old. Alternately, you can delete the file.

(4) You're done with your profile folder and you can restart Firefox now.

Any luck?

It's possible that the window is "off screen". If you make the Firefox tile active on the task bar and press this key combination, does it maximize into view? Alt+Spacebar > x (To clarify, that's Alt+Spacebar to open the window control menu, then the letter x to maximize the window.) ''If that works,'' try this: (1) Copy the following line of code to the clipboard: newwin=window.open(window.location.href);newwin.moveTo(0,0); (2) In the maximized window, press Ctrl+Shift+k to open the web console. (3) Press Ctrl+v to paste the line of code next to the caret (>) then press Enter to run it. A new copy of that page should open in a window positioned at the top left of the screen. (4) Switch back to the maximized window and close it first, before doing anything in the new window. ''If you can't maximize Firefox,'' you can rename or delete the settings file that stores the last window position. (1) Open your currently active Firefox settings folder (AKA Firefox profile folder). From the Start menu, paste this into the search box and press Enter: %APPDATA%\Mozilla\Firefox\Profiles You may only have one folder, but if you have multiple folders, look for the most recent. Click into your profile folder. (2) Switch back to Firefox and Exit completely. (3) Wait a few moments for Firefox to finish updating files in your profile folder, then rename '''localstore.rdf''' to something else, like localstore-bad.rdf or localstore.old. Alternately, you can delete the file. (4) You're done with your profile folder and you can restart Firefox now. Any luck?

Modified by jscher2000

Question owner

Oh man! thanks Jscher! that totally worked. All I was missing was the "alt-spacebar" trick. That brought up the command menu and then I clicked on "move" and held the left arrow button till window appeared in the main screen. From there I renamed the profile file. All is well now. Thank you!!

Oh man! thanks Jscher! that totally worked. All I was missing was the "alt-spacebar" trick. That brought up the command menu and then I clicked on "move" and held the left arrow button till window appeared in the main screen. From there I renamed the profile file. All is well now. Thank you!!