Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

yahoo mail keeps going to yim.com


I keep going to yahoo mail and recently most occasion it then runs to some website called http://www.yim.com/?redir=frame&uid=www50a154ce94ba49.13693812

Why is this happening? I have cleared history and cookies and not working to solve the problem.

Additional System Details

Sites Affected


Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • CouponNetwork Coupon Activator
  • Microsoft Lync 2010 Meeting Join Plug-in
  • GEPlugin
  • 5.1.10411.0
  • NDS Player Plugin
  • npPCShow Plugin
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Garmin Communicator Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Adobe PDF Plug-In For Firefox and Netscape


  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

  • Top 10 Contributor
2346 solutions 20793 answers

Are you saying Yahoo Mail is diverted or that a second window opens to that site, which looks completely unrelated? How are you accessing Yahoo Mail: typing the address, using a bookmark, using a link, etc.?

In case it's a sign of a security breach, you may want to run some supplemental scans. These two tools are highly regarded:

Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free

SUPERAntiSpyware : http://www.superantispyware.com/

Once you are confident your system is clean, you still might need to clean up your settings and add-ons in Firefox. But a little more info is needed on exactly what is happening.

Question owner

when I use my stored bookmark or go through the website manually it jumps to the next page. No new tab or windows opens pop up style just gets redirected to yim.com.

I have Malware Bytes ran that and claims it is clean.

  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Started in safe mode and still back to YIM.com

  • Top 10 Contributor
2346 solutions 20793 answers

Have you tried Internet Explorer to see whether anything unusual happens there?

Could you check your Firefox proxy setting and make sure it is set to No Proxy here:

orange Firefox button or classic Tools menu > Options > Advanced

On the "Network" mini-tab, click the "Settings" button

loran100 0 solutions 4 answers

Hi I am also having the problem.

1) I only have the issue with Firefox, Not with Internet explorer nor Chrome. 2) I have tried to uninstall reinstall firefox  : issue still there 3) I have tried to run it in safemode : issue still there 4) I have run the Malwarebytes Anti-malware software that detected no issue, but is enable to retrieve the latest base from the web, a strange error occur 5) I am using the same proxy for IE and Chrome

any idea? Thanks!

  • Top 10 Contributor
2346 solutions 20793 answers

To both minnz21 and loran100, can you try the following: disable all add-ons (except Flash and NoScript, if applicable) and test again.

orange Firefox button or classic Tools menu > Add-ons

Disable everything in both of these sections:

Plugins - except the Flash plugin ("Shockwave Flash 11.5")
Extensions - except NoScript if you use it

Then restart Firefox. Any change?

  • Top 10 Contributor
2346 solutions 20793 answers

Hi loran100, I don't understand your reference to a "strange error" from Malwarebytes. Perhaps try some additional tools such as the rootkit remover TDSSKiller from http://support.kaspersky.com/viruses/solutions?qid=208280684

loran100 0 solutions 4 answers

Hi Jscher2000,

I have tried TDSSKiller, but nothing was detected. Regarding the error, I have had an internal error (I am not able to reproduce because i have uninstalled).

By the way I have updated my flash player, and right now i do not have the error anymore... maybe?

hiking_feil 0 solutions 3 answers

I had a the same problem running in my Windows 7 Pro 64 bit computer at work. I'm going through a proxy. I have tried disabling all plug ins, and that didn't help. Problem only started a few days ago. Like others no issue in IE or Chrome. I also have no issue at home on my Vista 32 bit machine with no proxy. Similar set of plugins and firefox versions at home.

I don't think this is a root kit issue or something. We would be having a lot more problem than just yahoo mail if that were the case.

  • Top 10 Contributor
2346 solutions 20793 answers

I wonder whether there is a typo somewhere, since Yahoo uses yimg.com extensively. Obviously difficult to determine using View Source if the page redirects so quickly. And external tools generally do poorly capturing pages retrieved over a secure connection. If anyone who has this problem uses the NoScript extension, and keeps yim.com blocked, that might be helpful in determining whether the cause of the redirection is in the page(s)/script(s) served by Yahoo.

Modified by jscher2000

loran100 0 solutions 4 answers

Hi all

I am not facing the issue anymore , not sure why. The only thing I can imagine is the uodate of my flash player.... not sure why...

I have to say that I am not really confident about be ing rootkit free there, even if I have no evidence despite trying various antivirus/malware/root kits removal tools.

And also I have had a look inside my firewall logs, without being able to identify something suspect there...

hiking_feil 0 solutions 3 answers

I still have the problem on my Work PC. I don't believe the root kit theory. As I said before, if root kits wanted to make its presence known it would effect a lot more than yahoo mail.

For now I have using the IE+ plug in and forcing yahoo mail to be rendered in IE. It annoying through because now ad blocker doesn't work. As I said before I did try disabling my plug-ins that didn't make a difference.

loran100 0 solutions 4 answers

After 10 days without.... problem just came back...

yahoo redirected to YIM.com

and only on firefox...

piyush_soni 1 solutions 5 answers

Helpful Reply

There is certainly some problem related to proxy I think. I think I have fixed it for now by adding these two paths to my adblock plus filter :



In at least my case, it seemingly rerouted these requests to yimg.com and not yim.com when I did that. I will re-post if I see the error again after a few days. For now it's fixed.

@jscher2000, This is yim.com, not yimg.com. If you open the Inspector in Chrome and see the Network requests log, you might see that it does actually issue two actual 'Redirect' requests to yim.com to get some xframe.js. See the attached snapshot I uploaded. While it passes fine in Chrome, somehow some proxy authentication was failing in Firefox (checked in Firebug) which was eventually causing that actual redirect. I'm just guessing all of these. :)

EDIT : Oh, by the way, I could temporarily get rid of the problem by clearing ALL cache too (not just Yahoo), but the problem reappeared very soon after that.

Modified by piyush_soni

  • Top 10 Contributor
2346 solutions 20793 answers

My Firefox requests xframe.js using this URL:


You mentioned a proxy. Is it possible the proxy is "correcting" the URL??

Also, my Firefox loads the combo script (actually it calls that 3 times with different parameters) from s.yimg.com, not mail.yimg.com.

Modified by jscher2000

piyush_soni 1 solutions 5 answers

I'm not sure. But as I said above, when I blocked those yim links using Adblock plus, it started using yimg links to fetch the xframe. Or at least that's what I think might have caused it.

hiking_feil 0 solutions 3 answers

Thanks piyush_soni, by adding those adblocker rules yahoo mail now does work again in Firefox. Like others have posted here. I have seen the problem go away only to reappear again.

wyerichard 0 solutions 1 answers

Helpful Reply

I have two machines and this problem came up on one of them. Initially I switched JavaScript off and went back to the old yahoo mail but this frustrated me. So I RESET FIREFOX (Help Troubleshooting Information Reset Firefox) and this cured the problem.

horrorflix 0 solutions 2 answers

I had the same problem. I was able to stop it by installing BlockSite Plus. I added the full link (http://www.yim.com/?redir=frame&uid=www51518ceb0927f4.28149061) and the top-level domain name (yim.com) to the filter...