X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I change the default language for the spell checker?

Posted

Firefox spell-checker keeps defaulting to Hebrew and have a bunch of languages I didn't install on the list. I can manually switch to English every text box, but this is not really practical. Are there any settings to this damn thing?

I just installed ubuntu 12.10, with the latest Firefox.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Totem 3.4.3 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

That is probably an issue with Ubuntu that adds a lot of dictionaries by default.

What is the value of the general.useragent.locale pref (en-US) and the spellchecker.dictionary pref (en-US)?

The first sets which Firefox locale is currently installed and selected and the latter which dictionary is selected.
If the dictionary changes after a restart then an extension maybe changing that value.

You can try to copy the related line from prefs.js in the Firefox Profile Folder to a user.js file.

If you do not keep changes after a restart then see:

Question owner

My locale and spellchecker.dictionary are set to en-US, and I have no extensions that can affect it in any way (all the extensions I have are ones I used for a very long while over a bunch of different computers, never had this problem). The language setting is not per Firefox restart. it's per text-box. I can change it individually for the current textbox by right clicking and changing the language, but in the next one it will again be set to Hebrew.

obiza 0 solutions 3 answers

exact same issue here except my Firefox is defaulting to en-US dictionaries. as with OP, i'm on an en-GB system however my firefox only came with the en-US dictionary pre-installed. I downloaded the en-GB dictionary ( https://addons.mozilla.org/en-US/firefox/addon/british-english-dictionary/?src=api ) but I see no option to to set it as the default in the right click context and depressingly there are no options i can find for the dictionary inside the firefox general options, addon options or anywhere.

Is the dictionary really such an inflexible feature?

odoketa 0 solutions 1 answers

This is happening to me on a mac. Same everything, though - language is set on a textbox by textbox basis, default in about:config is english, but the French dictionary is the one that comes up. I manually installed the French dictionary - previously it had been English only, which had worked great. Now everything is assumed to be French