X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Adobe Flash does not work with firefox

Posted

Was using Firefox 14 with Flash v.11disabled all Real Player plug-ins, disabled protected mode for Flash and Youtube was working correctly. Then Firefox upgraded me to 16.0.2, and Youtube doesn't work. When I click on a Youtube video, it doesn't give me any error message, just a blank screen.

Downgraded to Flash v.10, still doesn't work. But Youtube works OK with IE and Chrome.

Chosen solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Try to disable hardware acceleration in Firefox.


You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin
Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Application Basics
Name
Firefox
Version
16.0.2
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
FireFTP
2.0.7
true
{a7c6cf7f-112c-4500-a7ea-39801a327e5f}
QuickJava
1.8.0
true
{E6C1199F-E687-42da-8C24-E7770CC3AE66}
RealPlayer Browser Record Plugin
15.0.6
true
{0153E448-190B-4987-BDE1-F256CADA672F}
Test Pilot
1.2.2
true
testpilot@labs.mozilla.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121024073032
browser.startup.homepage_override.mstone
16.0.2
extensions.lastAppVersion
16.0.2
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1351602404
places.history.expiration.transient_current_max_pages
79020
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics Family
Vendor ID
0x8086
Device ID
0x0126
Adapter RAM
Unknown
Adapter Drivers
igdumdx32 igd10umd32 igd10umd32
Driver Version
8.15.10.2509
Driver Date
8-31-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

y8y8 0 solutions 2 answers

You should reset all setup to original, it will ok

Question owner

Which setting are you referring to? How do I reset it?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Chosen Solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Try to disable hardware acceleration in Firefox.


You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin

Question owner

Ok, I've tried a combination of things and it sort of worked. I now am back in Firefox 14.0.1 and I am using Adobe 10.3.183.29. I've cleared the Youtube cache and the videos will load now. I am not sure if I should tried to update to the latest Adobe version. It worked for me before...but now sure about it now.

Question owner

Ok, I think things are working now. I have updated to Firefox 16.0.2. Cleared the youtube cache, updated my Flash to the lastest 11 version and it is working now. Thank you.

stoneynhvt 0 solutions 6 answers

No matter what I do, and I've done EVERYTHING that Firefox AND Adobe tell me to do, Flash just will not work sometimes.

For example, this Raw Story article. (http://www.rawstory.com/rs/2012/11/23/watch-live-black-friday-strikes-hit-walmart/). One of the embedded vids is telling me I need to update Flash (pic 1).

For kicks, I checked. See pic 2. Firefox and Flash are up-to-date, Windows is up-to-date, Hardware acceleration is OFF, Protected Mode is OFF, RealPlayer NOT installed.

Is it my settings or is the pairing eternally doomed?

stoneynhvt 0 solutions 6 answers

sorry...here's the flash version page...

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Hi stoneynhvt

Do you have any ad-blocking extensions or software running because on that last screenshot there is also content missing?

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.

stoneynhvt 0 solutions 6 answers

Answering a question, 2 actually, with a question isn't acceptable.

It appears that your answer to both my questions would be yes since the only extensions I have are ad/tracker blocking extensions or software.

Maybe Mozilla should make sure that the over 18 Million combined users of those extensions get the correct information in the first place.

Something like "Use of ad/tracker blocking extensions or software will interfere with Flash functionality."?

stoneynhvt 0 solutions 6 answers

Helpful Reply

Mozilla's silence on this speaks volumes, ladies and gentlemen.

Here's hoping things work better on Chrome...

Modified by stoneynhvt

FireFoxFan1 0 solutions 71 answers

Honestly, the response to this has been pitiful. I've given Firefox quite a bit of leeway because I love the layout of it, but the bullsh%t replies back to people asking questions is offensive. This is not professional, at all. How could a browser not have it's sh%t together with Flash, one of the most popular and necessary programs for surfing the net?

stoneynhvt 0 solutions 6 answers

Tried Chrome. Didn't like it.

And, it appears, that adblocking extensions ARE to blame for some flash problems as

Cor-El posted on 11/26/12 @ 5:17 PM "Note that some sites may block you from showing videos if they detect that you are blocking the ads. "

(https://support.mozilla.org/en-US/questions/942469?esab=a&s=&r=228&as=s)

Still waiting for a reply Cor-El....

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

You will always have to make sure that not other extensions or other anti-virus software or firewall software isn't blocking content.
There are already too many problems reported caused by the Flash plugin on its own, so you need to check this first to make sure that at least nothing is blocked otherwise.

Did you check this?

You can create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

stoneynhvt 0 solutions 6 answers

The response we've gotten to the ongoing Flash problems have been piecemeal and patronizing. It's frustrating enough when the software doesn't work.

There would appear to be something inherently wrong with the interoperability of Flash and Firefox.

I understand that extensions are, or may be, the culprit. But the answer has to be better than "Create a new profile", "disable add-ons/extensions" or "Safe Mode".

Modified by stoneynhvt