X
Tap here to go to the mobile version of the site.

Support Forum

A url in an email opens in the then open firefox window not a new one ( thus replacing original window.

Posted

Using Safari, when I click on a url in an email, it opens in a new window. Using Firefox, clicking on an url in an email replces the open firefox window with the new one. I want them both open.

Using Safari, when I click on a url in an email, it opens in a new window. Using Firefox, clicking on an url in an email replces the open firefox window with the new one. I want them both open.

Chosen solution

Is the email message in Firefox, and that page is navigating to the linked page, or is the email message in a separate program, and it's launching the URL in the last active Firefox window?

If the problem is an external link, could you check your setting for the following preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.open and pause while the list is filtered. Then look for this and if its value is not 2, change it to 2.

browser.link.open_newwindow.override.external

-1 = open_newwindow applies to external links (default)
3 = open external links in a new tab
2 = open external links in a new window
1 = open external links in active tab

Edit: Probably a good idea to check this one, too, and set it to 2 or 3, as you prefer.

browser.link.open_newwindow

3 = divert new window to a new tab (default) (checked*)
2 = allow link to open a new window (unchecked*)
1 = force new window into same tab

* First checkbox in Options > Tabs (on Mac, Preferences > Tabs)

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Java 1.3.1 Plug-in
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28

More Information

jscher2000
  • Top 10 Contributor
3998 solutions 34905 answers

Chosen Solution

Is the email message in Firefox, and that page is navigating to the linked page, or is the email message in a separate program, and it's launching the URL in the last active Firefox window?

If the problem is an external link, could you check your setting for the following preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.open and pause while the list is filtered. Then look for this and if its value is not 2, change it to 2.

browser.link.open_newwindow.override.external

-1 = open_newwindow applies to external links (default)
3 = open external links in a new tab
2 = open external links in a new window
1 = open external links in active tab

Edit: Probably a good idea to check this one, too, and set it to 2 or 3, as you prefer.

browser.link.open_newwindow

3 = divert new window to a new tab (default) (checked*)
2 = allow link to open a new window (unchecked*)
1 = force new window into same tab

* First checkbox in Options > Tabs (on Mac, Preferences > Tabs)

Is the email message in Firefox, and that page is navigating to the linked page, or is the email message in a separate program, and it's launching the URL in the last active Firefox window? If the problem is an external link, could you check your setting for the following preference: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''link.open''' and pause while the list is filtered. Then look for this and if its value is not 2, change it to 2. '''browser.link.open_newwindow.override.external''' -1 = open_newwindow applies to external links (<u>default</u>)<br> 3 = open external links in a new tab<br> 2 = open external links in a new window<br> 1 = open external links in active tab ''Edit: Probably a good idea to check this one, too, and set it to 2 or 3, as you prefer.'' '''browser.link.open_newwindow''' 3 = divert new window to a new tab (<u>default</u>) (checked*)<br> 2 = allow link to open a new window (unchecked*)<br> 1 = force new window into same tab '''*''' First checkbox in Options > Tabs ''(on Mac, Preferences > Tabs)''

Modified by jscher2000

Question owner

Thanks jscher2000,

This solved my problem.

Thanks jscher2000, This solved my problem.