X
Tap here to go to the mobile version of the site.

Support Forum

Two tabs now open, one telling me I'm updated, second for some sort of addon checker

Posted

First tab says congratulation Firefox is updated, I already know that, now it opens this tab each time I open my browser. Second tab is some sort of addon checker thingy.

Thought it might have happened with the upgrade to 16 from 15, down graded, happens there as well. So now back to 16 and still have the problem, except now I have this first tab opening as well.

First tab says congratulation Firefox is updated, I already know that, now it opens this tab each time I open my browser. Second tab is some sort of addon checker thingy. Thought it might have happened with the upgrade to 16 from 15, down graded, happens there as well. So now back to 16 and still have the problem, except now I have this first tab opening as well.

Chosen solution

Which problem do you still have?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.1.10111.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • Windows Activation Technologies Plugin for Mozilla
  • Winamp Application Detector
  • NPWLPG
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Usually Firefox changes a setting so you do not see that "you've updated page" on your next startup. If Firefox crashes before shutting down completely, the change might not be saved.

If you press Alt+Home or click your Home button, is your home page correct?

Usually Firefox changes a setting so you do not see that "you've updated page" on your next startup. If Firefox crashes before shutting down completely, the change might not be saved. If you press Alt+Home or click your Home button, is your home page correct?

Question owner

Yes, it opens that tab in addition to my home page, same for that addon thingy. Opens every time.

Yes, it opens that tab in addition to my home page, same for that addon thingy. Opens every time.
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

Did you check the Home page setting?

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Did you check the Home page setting? *https://support.mozilla.org/kb/How+to+set+the+home+page - Firefox supports multiple home pages separated by '|' symbols You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values. *http://kb.mozillazine.org/Preferences_not_saved

Question owner

Yes, looked very carefully there, not there, but did find it in the about:config page. First problem stopped, probably a glitch, second one remains.

Yes, looked very carefully there, not there, but did find it in the about:config page. First problem stopped, probably a glitch, second one remains.
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

Chosen Solution

Which problem do you still have?

Which problem do you still have?

Question owner

Second problem, tab about some addon checker which opens each and every time.

Second problem, tab about some addon checker which opens each and every time.
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

Did you try to delete the prefs.js file in case there is a problem with some prefs?

It is also possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to check if there is a compatibility update available.

If this hasn't helped then also try to delete the addons.sqlite file.

Did you try to delete the prefs.js file in case there is a problem with some prefs? It is also possible that there is a problem with the file(s) that store the extensions registry. Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to check if there is a compatibility update available. If this hasn't helped then also try to delete the addons.sqlite file.

Question owner

This appears to be the line in about:config

plugins.update.notifyUser;true

Have toggled it to false and the offending tab doesn't show up the next time I open Firefox, but the second time it does and when I check it has been toggled back to true. Also noticed some entries in there that were from an addon I tried out and dumped. Is it possible to simply delete lines in there? If so, how does one do it?

This appears to be the line in about:config plugins.update.notifyUser;true Have toggled it to false and the offending tab doesn't show up the next time I open Firefox, but the second time it does and when I check it has been toggled back to true. Also noticed some entries in there that were from an addon I tried out and dumped. Is it possible to simply delete lines in there? If so, how does one do it?
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

Do you see any blocked plugins on the about:addons (Tools > Add-ons > Plugins) page?

Do you see any blocked plugins on the about:addons (Tools > Add-ons > Plugins) page?

Question owner

Nope, nothing blocked.

Nope, nothing blocked.

Question owner

After locating the offending line in about:config, determined Firefox was re-writing the pref.js file to include this value. Simply edited the file, removied the two lines, then made the attributes of this file read only and it is gone.

After locating the offending line in about:config, determined Firefox was re-writing the pref.js file to include this value. Simply edited the file, removied the two lines, then made the attributes of this file read only and it is gone.
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

If you set the prefs.js file to read-only then you will likely end up with numbered (temporary) prefs-##.js files.

You can try to create an user.js file instead with that pref line.

user_set("plugins.update.notifyUser", false);
If you set the prefs.js file to read-only then you will likely end up with numbered (temporary) prefs-##.js files. You can try to create an user.js file instead with that pref line. <pre><nowiki>user_set("plugins.update.notifyUser", false);</nowiki></pre> *http://kb.mozillazine.org/user.js_file