Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have the latest Firefox and Flash updates installed, but firefox continuously prompts me to update flash and won't show streaming video such as youtube.

  • 14 replies
  • 4 have this problem
  • 8109 views
  • Last reply by dedanna1029

more options

I've gone through the forum and tried like a dozen things like uninstalling each component seperately and reinstalling. Also tried downloading realplayer like suggested in other threads, but it's not working. For example, I go to youtube and it says i need to upgrade adobe flash even though I have the latest install already and have installed and uninstalled several times to no avail. This has been going on for about a week or two. at first I thought it was because i had an older version of firefox, but updating didnt help at all and just gave me a less familiar GUI.

I have all windows updates and I'm running XP SP3

All Replies (14)

more options

I do not see "Shockwave Flash" (aka Flash) in your installed Plugins submitted with your question. Click "More system details" to the right of your question.

There are 2 versions of Flash, one for IE (ActiveX) and one for most other browsers including Firefox (Plugin). Windows users with IE and another browser installed should always download, save and install both (Google's browser updates itself automatically). Download the "EXE" installers. You must/should close browsers before running the downloaded/saved Flash installer.


Other -

You should update the "Adobe PDF Plug-In For Firefox and Netscape" (Adobe Reader)

Modified by TheOldFox

more options

I see that in my system details on this page it doesn't show that I have adobe flash installed, but I have downloaded and installed it multiple times to no avail. I also updated adobe pdf plugin as you suggested, but it's still saying I need Flash. Currently, my Add or Remove Programs show that I have Adobe Flash Player Plugin 11.4.402.287 installed

It's like firefox doesn't see it or isn't using it or something.

more options

In Windows Control Panel > Add or Remove Programs, you should have 2 entries. Do you have both?

  • Adobe Flash Player 11 ActiveX
  • Adobe Flash Player 11 Plugin

In Firefox, Add-ons > Plugins

  1. do you see "Shockwave Flash 11.4.402.287"?
  2. is it enabled?
  3. did it (or another version) show in the Plugin Check link? (disabled Plugins will not show in Plugin Check)

Did you try the steps in the article that I posted above?

Modified by TheOldFox

more options

In Add remove programs I have both the Activex and Plugin listings. In firefox addons > plugins it does not show any version of Shockwave Flash installed. I have tried the steps in the link earlier and again just now that you mentioned it, but it's still not showing up. I've tried uninstalling and reinstalling flash several times.

more options

Sorry, but some of your answers are a bit vague. Please try to be more specific with your responses.

  1. When you went to this link https://www.adobe.com/software/flash/about/ does it show that Flash is installed and show version 11.4.402.287?
  2. When uninstalling Flash, are you using Adobe's uninstaller and following the instructions on the following page (with all browsers closed)? - http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html
    • The above Adobe uninstaller will uninstall ALL versions of Flash on your system for ALL browsers.
    • After uninstalling, reinstall only the Plugin version of Flash and go to the Adobe test page to test the installation https://www.adobe.com/software/flash/about/

Are you running Windows XP 32-bit version or the somewhat rare 64-bit version. See - http://support.microsoft.com/kb/827218

  • Firefox requires the 32-bit versions of Plugins even on a 64-bit OS

If you are not comfortable with looking at the Windows registry, disregard the following.

  • Flash writes a registry key at location HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@adobe.com/FlashPlayer from which Firefox sees the Plugin
  • Is that key there with 7 keys in the right hand section of the screen?
more options

Try to run the Flash installer as Administrator via the right-click context menu: Run as -> Administrator

more options

One further thought. Have you tried deleting plugin.dat and maybe addons.sqlite in the Firefox Profile to reset the plugins "database" for Firefox.

  1. open the Firefox Profile folder, click Help > Troubleshooting Information > to the right of Profile Folder click Show Folder (opens a Windows Explorer/My Computer window to the location of your Firefox Profile)
  2. close/exit Firefox and wait 10-30 seconds for Firefox to complete closing
  3. delete (or rename) the two files plugin.dat and addons.sqlite
  4. restart Firefox and test Flash on the Adobe test link
  5. See - https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems#w_re-initializing-the-plugins-database

Modified by TheOldFox

more options

HI Oldfox, thanks for the help.

1. when I go to https://www.adobe.com/software/flash/about/ it prompts me to install missing plugin (flash).

2. I was uninstalling via control panel > add remove programs, but I just tried downloading the unistall exe and followed the directions carefully. including not having any other programs open, deleting all the folders specified, rebooting my machine, and installing as suggested without having windows open, etc. but even though I have adobe flash plugin in my add remove programs, firefox acts like it's not installed and says I need to install it again... ad finitum.

I'm running XP 32 bit logged in as an administrator and the registry key and the 7 subkeys are there. the first one says (default) no value set, the others are description, path, productname, etc.


AHhh....

I had about given up, but your last post did it. All I did was click "reset firefox" in the troubleshooting info screen and when it restarted it was all working and lists all my plugins in addons and everything. I didn't even know that page existed.

Thanks again!

more options

Glad that your problem is resolved.

Deleting the two files that I mentioned may have fixed your situation without doing the Reset. Creating a new profile, which is what the Reset Firefox function does, is generally the last thing that I suggest when there seems to be no other solution. You will need to reinstall your extensions, as the Reset Firefox does not reinstall them.

more options

This computer is on Mageia 2. We have tried installing flash-plugin from both the repositories and the .rpm at the flash site, to no avail. It is installed now, as is java, yet when we go to Tools-->Addons, it says no plugins are installed. I myself am wondering if the steps above apply to the Linux version of FF. I have tried FF versions from 10 through 17, and plugins are not showing up at all, or working at various flash or java sites. This, on both the tar.gz of Firefox, and the .rpm of it (Mageia still only supplies version 10 of the .rpm in the repos, so I tried the tar.gz from the FF site to get through version 17).

[root@localhost ~]# rpm -qa | grep flash --->flash-plugin-11.2.202.258-release (for this go-'round; before it was the Mageia version. I've gone back and forth several times, bringing down the browser and rebooting as well) iguanair-reflasher-0.99-1.svn959.6.mga1 kipi-plugins-flashexport-2.6.0-1.mga2

It's the same for the java (jdk, jre, whatever) plugins so far, open source from the Mageia repositories or from the .rpm from the site.

I've also tried the tar.gz of flash, and the .bin for the java plugin, yet I still go to the java site, it says it's not installed, go to youtube, it asks for the flash plugin.

What would be the Linux solution to this problem?

Also, meant to mention that regardless of what time this says it is in PST, I'm in Scotland, so 8 hours ahead of PST. Have been trying to find a resolution all morning, and came across this.

Thanks so much.

Modified by dedanna1029

more options

Did you check the time zone as set in your user profile?

If Firefox doesn't pickup plugins then they are installed in a location where Firefox doesn't check for them.

There are alternatives like creating a plugins folder /home/.mozilla/plugins or in the current profile folder and create a symlink to the plugins in that folder.

Also note that you need 32 versions of plugins for a 32 bit Firefox version.

more options

The problem being, that this computer doesn't use that profile. I am on my significant other's computer in Scotland for two months, not on my own. He had this issue before I came here. I will have to have him go to his and check, I suppose, but knowing him, it's correct. The 32-bit versions are installed.

Edit:

[root@localhost ~]# whereis flash-plugin flash-plugin: /usr/lib/flash-plugin

[root@localhost ~]# whereis java java: /usr/bin/java /etc/java /usr/lib/java /usr/share/java

IIRC, this is where Firefox looks for them, aye?

Modified by dedanna1029

more options

A possibility is to check the location of other plugins that are found.

See:

more options

There are none found by Firefox. None.

However, I did discover that it was blacklisting the nvidia card in this thing, so WebGL rendering, etc., is too.

We're going to do a reinstall of Mageia on this machine, this time from the dvd (we did it from the cd on this install), or do a net install of it, and see if there's any difference. We've found other issues as well.

Thank you for all of your help! I'll let you know what happens after the reinstallation, with Firefox.

Modified by dedanna1029